WordPress.org

Ready to get started?Download WordPress

Forums

EWWW Image Optimizer
[resolved] Installation problem on NGINX webserver (6 posts)

  1. Wanderlusters
    Member
    Posted 1 year ago #

    Hi there,

    I run my own VPS with NGINX and PHP-FPM on Debian 7.

    I have not been able to get EWWW to see/use the image optimisation plugins.

    I assume this is something to do with NGINX or PHP-FPM permissions but I haven't been able to figure it out.

    I've tried copying the plugins to /usr/bin but I don't think that's the issue as the debug log states it can see and check the files in wp-content/ewww. Also tar is installed but the plugin is not able to see that either.

    Plugin status and debug log: http://pastebin.com/HEuRQdE5

    Any help would be much appreciated.

    Cheers,

    Ben

    http://wordpress.org/extend/plugins/ewww-image-optimizer/

  2. nosilver4u
    Member
    Plugin Author

    Posted 1 year ago #

    Did you not get a big red warning about the exec() function being disabled? Because you should have, according to your debug log. Remove exec from your disabled functions, and try again.

  3. Wanderlusters
    Member
    Posted 1 year ago #

    Being relatively new to Linux, WordPress, php etc no I didn't.

    That fixed it though, thank you.

  4. Wanderlusters
    Member
    Posted 1 year ago #

    Also surely it should not have stated 'exec(): OK' under Plugin Status if that wasn't the case?

  5. nosilver4u
    Member
    Plugin Author

    Posted 1 year ago #

    Looks like I need to take a fresh look at the exec() detection code, something isn't right there. Thanks for catching that bug!

  6. nosilver4u
    Member
    Plugin Author

    Posted 1 year ago #

    Ok, it's fixed in the most recent dev version. Simple tweak to the regular expression I was using.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.