WordPress.org

Ready to get started?Download WordPress

Forums

Installation not working on Godaddy (12 posts)

  1. hierographix
    Member
    Posted 9 years ago #

    Here is the error message I get when I go to http://www.thetruthx7.com/wordpress/install.php:

    Warning: main(/home/content/n/a/z/nazorean/html/wordpress/wp-includes/wp-db.php): failed to open stream: Permission denied in /home/content/x/x/x/xxxx/html/wordpress/wp-settings.php on line 39

    Fatal error: main(): Failed opening required '/home/content/x/x/x/xxxx/html/wordpress/wp-includes/wp-db.php' (include_path='.:/usr/local/lib/php') in /home/content/x/x/x/xxxx/html/wordpress/wp-settings.php on line 39

    This is the code on line 38 & 39 of wp-settings.php:
    define('WPINC', 'wp-includes');
    require_once (ABSPATH . WPINC . '/wp-db.php');

    I have set my db name, username, password, and db host name (I already know I am part of that 1%) but I still get this error!!!!

  2. hierographix
    Member
    Posted 9 years ago #

    Sorry, the correct url is http://www.thetruthx7.com/wordpress/wp-admin/install.php

    Please help!

  3. Mark (podz)
    Support Maven
    Posted 9 years ago #

    Set the folder permissions to 755 if they are not already.
    If that does not work, try 766

    Try the same permissions on the files that are mentioned.

  4. hierographix
    Member
    Posted 9 years ago #

    That fixed one problem. Now I get the message: "No input file specified"

  5. hierographix
    Member
    Posted 9 years ago #

    Podz,
    thanks for your help. I figured the last part out on my own. I am on a mac g4 and I was using safari instead of IE to set up the blog.

    works fine now. I can view the blog in safari, but it seems I can't set it up in safari.

  6. Mark (podz)
    Support Maven
    Posted 9 years ago #

    Glad you got it sorted :)

    I do keep saying .... send me a mac and I'll be able to help better !

  7. michaelc
    Member
    Posted 9 years ago #

    Be sure to log that as a bug. We Mac folk have to take responsibility for WP working properly with our stuff.

    (I use Firefox most of the time, so I never had that issue.)

  8. jimpatton63
    Member
    Posted 9 years ago #

    I'm having problems on godaddy, too, though it is proably my fault not theirs.

    I am a completed novice and here is the error I get:

    Warning: main(/home/content/j/i/m/jimdandy63/html/wordpress/wp-includes/functions-post.php): failed to open stream: No such file or directory in /home/content/j/i/m/jimdandy63/html/wordpress/wp-settings.php on line 82

    Warning: main(/home/content/j/i/m/jimdandy63/html/wordpress/wp-includes/functions-post.php): failed to open stream: No such file or directory in /home/content/j/i/m/jimdandy63/html/wordpress/wp-settings.php on line 82

    Fatal error: main(): Failed opening required '/home/content/j/i/m/jimdandy63/html/wordpress/wp-includes/functions-post.php' (include_path='.:/usr/local/lib/php') in /home/content/j/i/m/jimdandy63/html/wordpress/wp-settings.php on line 82

    Does anyone have any idea what this means?

    Thanks

    Jim Patton

  9. Mark (podz)
    Support Maven
    Posted 9 years ago #

    Yup.
    the files are not where WP expects them to be.

    Did the WP download unzip into 4 folders and some files, and did you ftp them correctly in that state to your site ?

  10. jimpatton63
    Member
    Posted 9 years ago #

    Yes they did. I logged in via ftp and created a folder called wordpress. Then I uplaoded all of the files and folders into that folder. They appear to be in that folder.

    I tired two different settings in the wp-config.php:

    'DB_HOST', 'localhost"
    'DB_HOST', 'mysql31.secureserver.nst' (This is what appears on godaddy.)

    The second one gave me the error in my last post. When I used 'localhost' it said that the name or password was wrong or that it couldn't find the database in 'localhost.

    Jim Patton

  11. Mark (podz)
    Support Maven
    Posted 9 years ago #

    On Godaddy, the name of the database is also the username.
    The password is obviously just that.

    The host has always been the one with 'secureserver' in it.

  12. jimpatton63
    Member
    Posted 9 years ago #

    That's how I have it setup...

    But I still get that long error message.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.