WordPress.org

Ready to get started?Download WordPress

Forums

installation issues with wp-config.php (1 post)

  1. knowlimit
    Member
    Posted 9 years ago #

    Everything appears to be working except that I cannot access the blog index page.

    Install WP: success
    Create DB tables: success
    Log in as administrator: success
    Write test post: success

    I cannot click on any link to view the blog page or access directly.

    Any attempts lead to the "There doesn't seem to be a wp-config.php file."

    I have:

    - created the wp-config thru the web interface and manually
    - verified the paths, CHMODs and folder integrity
    - deleted and recreated the DBs using the web interface and phpmyadmin

    Whenever I click the web interface. the next page begins "The file 'wp-config.php' already exists."

    I've deleted the DB via phpmyadmin, then click "try installing again".

    First and second installation steps are successful; and I log in without issues, but I still cannot click on any links to view site.

    In addition, I have re-downloaded and re-installed the files via FTP, but the problem still occurs.

    I also tried changing:

    define('ABSPATH', dirname(__FILE__).'/'); creates:
    Fatal error: Failed opening required '//wp-settings.php' (include_path='') in //wp-config.php on line 19

    define('ABSPATH', dirname(__FILE__)); creates:
    Fatal error: Failed opening required '/wp-settings.php' (include_path='') in //wp-config.php on line 19

    In the wp-config.php, I have changed the line: define('ABSPATH', dirname(__FILE__).'/');

    to

    define('ABSPATH','/home/taktikz/public_html/blog/');

    and

    define('ABSPATH','/home/taktikz/public_html/blog'.'/');

    Both changes gets me pass the errors and lead to the "Already installed" screen.

    I'm right back where I started.

    Any assistance is appreciated.

Topic Closed

This topic has been closed to new replies.

About this Topic