WordPress.org

Ready to get started?Download WordPress

Forums

Installation Help *sigh* php extension problems (7 posts)

  1. Vanth
    Member
    Posted 8 years ago #

    Ok, I've spent all day trying to figure this out and am here at my wits end! I edited the wp-config-sample.php file and renamed it to wp-config.php. Then I uploaded all the wordpress files to my web host. When I log onto my site via ftp I get the following directory tree:

    /db
    /logs
    /wwwroot

    I copied all the files into the /wwwroot folder. Which is correct. In step 5 of the WordPress instructions it says:

    Step 5:
    Run the Install Script
    Using your favorite web browser, visit wp-admin/install.php within the directory into which you just installed WordPress on your web site.

    I typed my domain in:
    http://legionsofthealliance.com/wp-admin/install.php
    and all I get for a response is:

    PAGE NOT FOUND

    My hosting plan supports:
    Scripting -- ASP, .NET 2, Perl, CGI-Bin, PHP5
    Database -- Access or MSSQL, MySQL 4.1

    I had created a database in my HELM control panel for my hosting and edited the wp-config file with the database name, username and password. So that should be correct.
    Mainly, I am wondering why IE6 keeps telling me it cannot find the page "install.php" as above. I can say that my server has no folder called "localhost", which I am not sure is a problem. I have always used NetObjects Fusion for my web sites and I thought WordPress looked fun to try.
    I am not a coder and this may be too much for me as I have never worked with server side and database configuration.

    Any help is appreciated.

  2. pizdin_dim
    Member
    Posted 8 years ago #

    It sounds like a file permission thing. Are you sure that the webserver user can read the files?

  3. Michael Bishop

    Posted 8 years ago #

    have you run other PHP scripts on your server? If not, double check that php is configured but putting this line <?php phpinfo(); ?> in a file, call it test.php upload it to your server at root, then navigate to the file at http://www.legionsofthealliance.com/test.php

    if php is configured you'll see several pages worth of data about the php configuration. if not, then we know the problem.

  4. Vanth
    Member
    Posted 8 years ago #

    I placed the below line:
    <?php phpinfo(); ?>
    in notepad exactly as shown and saved it as test.php and uploaded it to my web server in the root. When I navigated to http://www.legionsofthealiance.com/test.php
    I received the same:
    THE PAGE CANNOT BE FOUND error page

    I'll contact technical support for my hosting and ask if they have PHP set up.

    And, "No," I have never run a php script on my web server.
    Thanks for a point in the right direction.

  5. mstandlee
    Member
    Posted 8 years ago #

    I am having a similar problem. I get "error establishing a database" and I have checked it over & over. I don't seem to know the problem. My domain is: http://www.mindysdesigns.com/Blog/wp-admin/install.php

    Is it a problem that I put the files inside the folder "Blog"?

  6. Vanth
    Member
    Posted 8 years ago #

    Problem is fixed. My hosting company had not enabled PHP. Thanks for the assistance.

  7. Michael Bishop

    Posted 8 years ago #

    mstandlee, your issue isn't configuration of PHP on the server, your issues are probably in your config.php file. Double check that you have the correct database name, user name, and password. If they are check out correctly, then you may want to check with your host to be sure that localhost is where you are connecting to the database. I know Dreamhost that's not the case.

    Vanth, glad you got things sorted out. It seems a lot of IIS servers don't have PHP configure by default.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags