WordPress.org

Ready to get started?Download WordPress

Forums

Installation fell apart (12 posts)

  1. 5mininstallmyassss
    Member
    Posted 8 years ago #

    Ok, so I was following the install instructions step-by-step.
    "1) Download and unzip the WordPress package. " ( k that's simple and DONE)
    "2) Create a database for WordPress on your web server, as well as a MySQL user who has all privileges for accessing and modifying it." (DONE and DONE)
    "3) Rename the wp-config-sample.php file to wp-config.php, then open it in your favorite text editor and fill in your database details."
    (DONE and DONE and DONE)

    ....then just as I was getting cocky and bigheaded about how easy this was, I got to step 4, and found that the quality of the instructions greatly dropped down, and it was all down hill from there. Now I'm seeing a 404 Not Found when trying to access my /wp-admin/install.php
    So I'm backtracking to where I swerved off the path and asking for someone to guide me by the hand starting at step 4:"Place the WordPress files in the desired location on your web server:"

    I connect to my server via SmartFTP client in an attempt to upload my wordpress contents to my server and I come upon a fork in the road which is not mentioned in the instructions.
    Which folder am I supposed to FTP the WordPress contents to? I see 5 folders to choose from: mail, public_ftp, public_html, tmp, and www.
    Which one of these would be my root directory?
    By the way, since I didn't know which was the right folder to put it in, I uploaded WordPress to them all, but it still didn't work.
    So does that mean, something else is impeding me?
    I doubt I have a database problem because I looked in my CPanel and clicked on "MySQL Databases" and it shows that I have the wordpress database with the user, but with no tables.

  2. vkaryl
    Member
    Posted 8 years ago #

    public_html is your "root" folder for your website files. It's generally a good idea to put WP's folders and files into a subfolder named whatever you like - "wordpress", "blog", or something specific to the subject your blog will address.

    Once the install completes properly, the tables will be created in the database and populated with WP specific data.

  3. moshu
    Member
    Posted 8 years ago #

    1. Upload the WP files in the public_html.
    2. Check and re-check if the user is added to the database!

  4. 5mininstallmyassss
    Member
    Posted 8 years ago #

    haha, Thanks for the fastest forum reponses I've ever been witness to.
    Thanks for helping clear up the that public_html was the folder I should be focusing on.
    Alas I found out the real problem. It appears I'm a duma$$, and that the 5 min install doesn't apply to my kind.

    Because my ftp client doesn't upload subfolders and sub-subfolders, it wasn't uploading the files inside the /wp-admin folder. It only uploaded the top folder files and not the subdirectory files. I had to manually create all the subfolders and upload their files. SmartFTP sucks... Anyone have any suggestions on a better free FTP client?
    So anyways that was my problem.

    I'll be changing my forum user name to "5mininstallforpeopleWhoAren'tDumasssesLikeMe"

  5. Marc
    Member
    Posted 8 years ago #

    Must be a setting within Smart FTP.

    I have used it for about a year with no problems.

  6. Basilisk
    Member
    Posted 8 years ago #

    SmartFTP uploads all files and folders fine for me - are you using the latest release? It should be working fine on default settings.

  7. farrokh
    Member
    Posted 8 years ago #

    My installation is having a problem too. The blog doesn't install fully and properly. After it gives me my login and password, I can't login. One thing I did find out though, was that some files are not accessible through http. What I mean is, for examole, just the file readme.html in my website is located at :
    negahi.com/php_uploads/readme.html

    Now, I can access it by typing ftp://negahi.com/php_uploads/readme.html

    But if I type http://negahi.com/php_uploads/readme.html,

    it tells me the file is not found and it is the same case with the wp-login.php and god knows what other files.

    In the case of the readme.html file I changed its properties through ftp but it didn't help :(

    Any ideas?

  8. moshu
    Member
    Posted 8 years ago #

    So, your blog is going to sit in the "php_uploads" directory?

  9. farrokh
    Member
    Posted 8 years ago #

    Yes it is.

  10. Herschel
    Member
    Posted 8 years ago #

    farrokh: The readme page is available at http://negahi.com/readme.html, without php_uploads. It looks like php_uploads is your root directory for your web site.

  11. oriecat
    Member
    Posted 8 years ago #

    I use and like FileZilla.

  12. farrokh
    Member
    Posted 8 years ago #

    I created another folder and used WS_FTP and it worked.

    Thank you very much.

Topic Closed

This topic has been closed to new replies.

About this Topic