WordPress.org

Ready to get started?Download WordPress

Forums

Installation fails on Yahoo webhosting ... (15 posts)

  1. coderkeitaro
    Member
    Posted 9 years ago #

    I am having a problem with installing WordPress on my Yahoo webhosted server.

    I am trying to install it on a subdomain, not that that should make too much of a difference.

    The specs are;
    MySQL 3.23.49
    PHP 4.3.6
    WordPress 1.5

    I keep getting "Error establishing a database connection" message on the install page.
    I have set up a new database called "wordpress" with user "wordpress" with full rights to that database, as per the instructions.

    Does anyone have any clues why this keeps on happening?

  2. Jinsan
    Member
    Posted 9 years ago #

    it should be accountusername_wordpress

  3. coderkeitaro
    Member
    Posted 9 years ago #

    eh?
    What should be?
    The database name? username?

  4. coderkeitaro
    Member
    Posted 9 years ago #

    Actually, I found out what it was.
    The "host" should be "mysql".
    The databse name and user name are OK.

  5. coderkeitaro
    Member
    Posted 9 years ago #

    OK, now I get another problem.
    The admin pages are accessible but not the index.php!

  6. coderkeitaro
    Member
    Posted 9 years ago #

    OK, Yahoo hosting FTP server failed on me.
    Only half the theme files were there.

    I have it up and running now...

    mission successfull

    Thanks all.

  7. pajryan
    Member
    Posted 9 years ago #

    I was having trouble with this as well, and this thread helped me get things working. But I wanted to clarify, in case someone else comes along:

    In your config.php - the "host" needs to be "mysql"

    but in your permissions for the wordpress user, the host needs to be "localhost" (if using phpMyAdmin, drop down on the "host" field and choose "Local").

    This got things up and running smoothly.

    Now I just need to see if Yahoo will let me use permalinks (.htaccess)... we'll see.

  8. pajryan
    Member
    Posted 9 years ago #

    A follow-up (in case this is useful to someone other than me):

    Yahoo (I use small business Standard) doesn't allow the creation of a .htaccess file. (they won't allow any filenames that start with '.'). So permalinks won't work.

    There is the permalinks work around - using something like "/index.php/archives/%year%/%monthnum%/%day%/%postname%/"

    By prefixing the structure with /index.php, it'll work but always show index.php in the URL. I don't like it... but it's better than looking for a new host right away (who has time for such things?)

  9. viharsheth
    Member
    Posted 8 years ago #

    Okay, I'm having trouble with a Yahoo installation. It won't let me create a new user "wordpress" in the privlegdes section of the database "wordpress" that I've made. I have another user name there that I've given access to "wordpress" the database. I've configured my wp-config.php file the way you've suggested in this thread and the way they explain on WordPress's site and neither works. I keep getting an error saying: "This either means that the username and password information in your wp-config.php file is incorrect or we can't contact the database server at localhost. This could mean your host's database server is down." Can someone please post exactly what my file should say? This is what I have right now (my wordpress files and folders are installed in my root directory:
    -----
    <?php
    // ** MySQL settings ** //
    define('DB_NAME', 'wordpress'); // The name of the database
    define('DB_USER', 'username'); // Your MySQL username
    define('DB_PASSWORD', '**********'); // ...and password
    define('DB_HOST', 'localhost'); // 99% chance you won't need to change this value
    -----

    Thanks.

  10. moshu
    Member
    Posted 8 years ago #

    It was said above several times that you should have "mysql" instead of localhost...

  11. brittanie
    Member
    Posted 8 years ago #

    Yes, we who use Yahoo Hosting are the 1 percent who do need to change that value.

  12. DaveM
    Member
    Posted 8 years ago #

    I am a new user having a different problem with Install.php When i run install it launches a new window which contains amonst other info :Already Installed
    You appear to have already installed WordPress. To reinstall please clear your old database tables first.

    ') . ''); $wpdb->show_errors(); switch($step) { case 0: ?>
    ReadMe documentation at your leisure.'), '../readme.html'); ?>

    And then it asks me continue to Step 2.

    HELP Please - any idea what is going on ???

    Dave

  13. moshu
    Member
    Posted 8 years ago #

    I don't see how the install.php would open a new window... By "running" do you mean typing in the address bar of your browser something like:
    yoursite.com/wp-admin/install.php, right?

  14. workerb
    Member
    Posted 8 years ago #


  15. DavidHardin
    Member
    Posted 8 years ago #

    I also am a user of Yahoo Small Business. The hostname MySQL and creating the database were my big hangups. I found the answers here. Thank you all!

    One thing I haven't figured out is with wordpress in my root, how do I make my domain.net show my blog instead of going to domain.net/wordpress.

    Thanks again in advance.

Topic Closed

This topic has been closed to new replies.

About this Topic