WordPress.org

Ready to get started?Download WordPress

Forums

Installation Error 404 (23 posts)

  1. kbennett
    Member
    Posted 6 years ago #

    I created the database, edited the config file to the exact specifications, and successfully uploaded all the files. When I use FX to browse to the install.php file I get "Error occurred: 404 - not found
    Apache Server at: d1043795.dotsterhost.com"

    I've reread the installation process and double checked the details and cannot, for the life of me, figure out what I'm doing wrong.

    None of the tips from the forum archives addressing a similar issue seem to work either.

  2. whooami
    Member
    Posted 6 years ago #

    Are you revisiting this topic?

    http://wordpress.org/support/topic/132516?replies=18

    Because like I explained over there, this:

    http://www.offthewoodwork.com/webspace/httpdocs/wordpress/wp-admin/install.php

    is NOT a proper url.

    Your install.php is right here:

    http://www.offthewoodwork.com/wordpress/wp-admin/install.php

    and this:

    http://www.offthewoodwork.com/wordpress/wp-admin/setup-config.php

    ...is telling you that you need a wp-config.php

    ---------

    If you are attempting to install wp elsewhere, it would be useful to have updated information.

  3. whooami
    Member
    Posted 6 years ago #

    Have you heard of install4free?

    http://install4free.wordpress.net/

    Im not trying to be rude, merely suggesting that since you appear to be struggling with the understanding that webspace and httpdocs are not to be included in urls, maybe you really ought to get outside assistance.

    This is very fundamental stuff and you're going to have a get a grasp on the basics or you're going to have one hell of time trying to anything with your blog once its ever correctly installed.

  4. whooami
    Member
    Posted 6 years ago #

    http://www.offthewoodwork.com

    that 403 error, btw, might be caused by the permissions on either your webspace directory OR your httpdocs

    they need to be 755.

    OR

    It might be caused by the fact that you have no content in it thats viewable, since the lack of this:

    http://www.offthewoodwork.com/wp-config.php

    tells me that youre still working off that other directory.

  5. kbennett
    Member
    Posted 6 years ago #

    Yes, I am. I have cleaned out the old installation completely (which was causing problems the last time) and wiped the database clean.

    I attempted to use the http://www.offthewoodwork.com/wordpress/wp-admin/install.php path.

    Where is the wp-config? I cannot locate it in the original extraction in the wp-admin directory. Should I transfer it over from the wordpress directory? Or am I missing something?

  6. whooami
    Member
    Posted 6 years ago #

    the wp-config need to be in the root of where you are trying to install wp.

    Its right here:

    http://www.offthewoodwork.com/wordpress/wp-config.php

    wp doesnt "see" it though

    --

    If you want, I will install wp for you ..

    just email me at whoo AT village-idiot DOT org and give me the necessary info

  7. kbennett
    Member
    Posted 6 years ago #

    Ok, when I followed the installation instructions it said to rename and edit the wp-config-sample to just wp-config. I've taken the original and added to the directory and now I get a "Sorry, I can't write to the directory. You'll have to either change the permissions on your WordPress directory or create your wp-config.php manually."

  8. kbennett
    Member
    Posted 6 years ago #

    e-mail sent.

  9. whooami
    Member
    Posted 6 years ago #

    I said previously:

    .. the permissions on either your webspace directory OR your httpdocs

    they need to be 755.

    You need to check the permissions on both those directories.

    I got your e-mail -- Im not really willing to do what we can do here via email. My offer was to install it for you -- if you would rather gt help thats fine, but we can do that here. :)

  10. kbennett
    Member
    Posted 6 years ago #

    Ok, I've set both permissions to 755.

  11. whooami
    Member
    Posted 6 years ago #

    and the httpddocs/wordpress/ directory as well ..

  12. kbennett
    Member
    Posted 6 years ago #

    They all appear to have the numeric value of 755 now.

  13. whooami
    Member
    Posted 6 years ago #

    ya know, at this point, without seeing everything (literally) I cant make any more suggestions.

  14. kbennett
    Member
    Posted 6 years ago #

    check e-mail

  15. whooami
    Member
    Posted 6 years ago #

    this looks to be resolved.

    there were two things going on

    1. the wp-config.php wasn't in the proper directory

    2. in editing, he had broken the comments. ie, this:

    // You can have multiple installations in one database if you give each a unique prefix

    was now this:

    // You can have multiple installations in one database if you give each a

    unique prefix

    Obviously that would cause an error.

  16. kbennett
    Member
    Posted 6 years ago #

    which directory should wp-config have been in? I was under the impression it went under the wp-admin directory (as moving it is never mentioned in the installation instructions.

    Thanks whoo. Very much appreciate your help.

  17. whooami
    Member
    Posted 6 years ago #

    the wp-config need to be in the root of where you are trying to install wp.

    That might have been confusing at first glance, you had it in httpddocs (atleast the one I saw) it belongs "where" you are installing wp, which, in your case, is inside the folder named wordpress.

    It belongs where wp-blog-header.php is.

    If you have another one inside wp-admin, delete it.

  18. whooami
    Member
    Posted 6 years ago #

    and remove the wp-admin/install.php

    and remove wp-admin/setup-config.php

    and remove the readme.html and the wp-config-sample.php also.

    You dont need those 4 files after youve installed.

  19. kbennett
    Member
    Posted 6 years ago #

    Jeez, I hate to keep bugging you, but as soon as I clicked 'options' to begin setting things up, the page went blank. Logging out and logging back in also shows a blank page.

    I don't know what else could go wrong at this point.

  20. whooami
    Member
    Posted 6 years ago #

    you deleted the wp-config out of the wordpress directory.

    you need to read very carefully what i write, and I didnt say to do that :)

  21. kbennett
    Member
    Posted 6 years ago #

    I don't think I touched the wp-config. I pulled the wp-config-sample, the install.php, the setup-config and the liecense agreement.

  22. whooami
    Member
    Posted 6 years ago #

    and now your back - but you have changed your url settings..

    you REALLY need to do some reading -- you cant just go in and change things if you dont know what you are doing.

    <link rel="stylesheet" href="http://www.offthewoodwork.com/wp-content/themes/default/style.css" type="text/css" media="screen" />

    this tells me that you have changed the setting that tells wordpress where your files are.

    Your files are not at http://www.offthewoodwork.com/...

    they are here:

    http://www.offthewoodwork.com/wordpress/....

    Now that you have done that you can either use phpmyadmin to fix that, or you can reinstall.

  23. whooami
    Member
    Posted 6 years ago #

    I don't think I touched the wp-config. I pulled the wp-config-sample, the install.php, the setup-config and the liecense agreement.

    The setup-config is still right here:

    http://www.offthewoodwork.com/wordpress/wp-admin/setup-config.php

Topic Closed

This topic has been closed to new replies.

About this Topic