WordPress.org

Ready to get started?Download WordPress

Forums

Installation Error (11 posts)

  1. CJField
    Member
    Posted 9 years ago #

    I keep getting this error:

    Warning: main(/home/kerih/public_html/wp-includes/wp-db.php): failed to open stream: No such file or directory in /home/kerih/public_html/wp-settings.php on line 39

    Fatal error: main(): Failed opening required '/home/kerih/public_html/wp-includes/wp-db.php' (include_path='.:/usr/lib/php:/usr/local/lib/php:/tmp') in /home/kerih/public_html/wp-settings.php on line 39

    Where is line 39 and how do I fix it??

  2. CJField
    Member
    Posted 9 years ago #

    Ok, now I must have fixed something because I'm getting this:

    Error establishing a database connection
    This either means that the username and password information in your wp-config.php file is incorrect or we can't contact the database server at DB_HOST.

    Are you sure you have the correct username and password?
    Are you sure that you have typed the correct hostname?
    Are you sure that the database server is running?
    If you're unsure what these terms mean you should probably contact your host. If you still need help you can always visit the WordPress Support Forums.

    So here I am, in the forums!

  3. oriecat
    Member
    Posted 9 years ago #

    Did you check your wp-config data?

  4. CJField
    Member
    Posted 9 years ago #

    Yes, I think. I am using the sign in name and password that was created when I created the wordpress database.

    Here is the info from the SQL database area:
    Perl $dbh = DBI->connect("DBI:mysql:kerih_wordpress:localhost","kerih_kerih","<PASSWORD HERE>");
    PHP $dbh=mysql_connect ("localhost", "kerih_kerih", "<PASSWORD HERE>") or die ('I cannot connect to the database because: ' . mysql_error());
    mysql_select_db ("kerih_wordpress");

    and this is what I put in the wp-config data:
    <?php
    // ** MySQL settings ** //
    define('kerih_wordpress', 'wordpress'); // The name of the database
    define('kerih_kerih', 'username'); // Your MySQL username
    define('toebaby', 'password'); // ...and password
    define('localhost', 'localhost'); // 99% chance you won't need to change this value

  5. iand
    Member
    Posted 9 years ago #

    the values should be:
    // ** MySQL settings ** //
    define('DB_NAME', 'kerih_wordpress'); // The name of the database
    define('DB_USER', 'kerih_kerih'); // Your MySQL username
    define('DB_PASSWORD', 'toebaby'); // ...and password
    define('DB_HOST', 'localhost'); // 99% chance you won't need to change this value

    and I REALLY suggest you change that password asap.

    I was going from memory, appropriate bits changed now.

  6. oriecat
    Member
    Posted 9 years ago #

    Close, but you need it to look like this:

    define('DB_NAME', 'kerih_wordpress'); // The name of the database
    define('DB_USER', 'kerih_kerih'); // Your MySQL username
    define('DB_PASSWORD', 'toebaby'); // ...and password
    define('DB_HOST', 'localhost'); // 99% chance you won't need to change this value

  7. CJField
    Member
    Posted 9 years ago #

    Did that, still getting:

    Warning: main(/home/kerih/public_html/wp-includes/wp-l10n.php): failed to open stream: No such file or directory in /home/kerih/public_html/wp-settings.php on line 69

    Fatal error: main(): Failed opening required '/home/kerih/public_html/wp-includes/wp-l10n.php' (include_path='.:/usr/lib/php:/usr/local/lib/php:/tmp') in /home/kerih/public_html/wp-settings.php on line 69

  8. iand
    Member
    Posted 9 years ago #

    Check your uploaded files - is wp-l1on.php in the wp-includes folder? May as well check all the files were uploaded correctly too.

  9. CJField
    Member
    Posted 9 years ago #

    Ok, that's working, BUT (and isn't there always a butt??)

    I CANNOT, for the life of me, figure out how to change the password to the SQL database user!!

  10. iand
    Member
    Posted 9 years ago #

    Maybe time for Podzs' tutorial? - I am getting out of my depth now..
    http://www.tamba2.org.uk/wordpress/ check the installation section (top left) for your flavour of control panel.

  11. CJField
    Member
    Posted 9 years ago #

    Thanks!!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.