WordPress.org

Ready to get started?Download WordPress

Forums

Installation and intial login errors (6 posts)

  1. cgfrench
    Member
    Posted 10 years ago #

    This is my first install of WordPress. AFAICS I followed the instructions in the Readme.
    Installed on my local machine (Win2k), PHP Version 4.2.3, MySQL 3.23.52
    when running wp-install.php I had a couple of errors reported. On the first page I had
    'Notice: Undefined index: step in J:\webserver\webpages\wp\wp-admin\wp-install.php on line 7'
    At Step 3 I had
    'Notice: Undefined variable: admin_email in J:\webserver\webpages\wp\wp-admin\wp-install.php on line 713'
    Though all otherwise seemed to go ok, and it gave me a username 'admin' and the random passoword to login.
    When I tried to login I got:
    'Notice: Undefined variable: _wp_installing in J:\webserver\webpages\wp\wp-settings.php on line 7
    Warning: Cannot add header information - headers already sent by (output started at J:\webserver\webpages\wp\wp-settings.php:7) in J:\webserver\webpages\wp\b2login.php on line 125'
    The 'Warning' was repeated for various other line numbers in the b2login.php script.
    and that was that.
    I did have a look in some of the relevant files, but It's all bit beyond me.
    Any suggestions?

  2. cgfrench
    Member
    Posted 10 years ago #

    PS
    I forgot to mention that I have checked the wp-setting.php file for blank lines at the end as this was mentioned as a possible source of the errors (with other files) in previous threads.

  3. cgfrench
    Member
    Posted 10 years ago #

    Ahh, thanks, that seems to have sorted that problem - editted the php.ini file.
    However, once I complete the intial login page my webserver retruns a '404'page not found error'
    I'm not sure how to work out what url it thinks it is looking for, as i assume it is some path/url problem somewhere.

  4. Impulz
    Member
    Posted 10 years ago #

    Did you enter the korrekt URL (including http:// ) during the installation?
    Can you see in the address bar where you are redirected? Else you have to look into your webserver errorlog for the 404 error.

  5. cgfrench
    Member
    Posted 10 years ago #

    The URL is correct (other links on the login page work ok)
    Unforutnaltey the logs don't help that much:
    "POST /wp/b2login.php HTTP/1.1" 404 0 "http://www.chrisfrench.org/wp/b2login.php" ""
    is a typical entry
    Looking at the php code for the page, b2login, calls itself to deal with the input to the form, quite why this means the server says it can't find th page i don't know.
    correct info, or even no info, different browsers (Opera and IE), clearing out the databse and reinitializing - all get the same response.

  6. cgfrench
    Member
    Posted 10 years ago #

    Well I got past this problem by installing a different webserver (Omniserve). Xitami ws a bit flakey for me anyway.
    Got another problem now thouhg (in a new thread.)

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.