WordPress.org

Ready to get started?Download WordPress

Forums

Installation (16 posts)

  1. khlucey
    Member
    Posted 1 year ago #

    I have tried to upload a new theme "Chameleon" from Elegant Themes - and WP says it has uploaded, but when I go to look at the preview it gives me:
    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 7680 bytes) in /data/26/2/45/6/2371169/user/2602189/htdocs/solarsister/wp-admin/includes/theme.php on line 18

    Is this an issue with my host not having enough memory? or something else? where do I begin to fix this error?

    Thanks in advance for your help.

  2. Abhishek Ghosh
    Member
    Posted 1 year ago #

    Open your that WordPress file (.../theme.php) from FTP software and navigate to the directory where you have installed WordPress. Check the file by opening it any text browser (at the end there might be and extra space).

    After that from there, locate ./wp-config.php file. You will need to open it in text editor. Change the value somewhere close to the top of that file (search it inside the text):

    @ini_set('memory_limit','128M');

    Advanced :

    We have increased the php memory limit from wp-config. We can do it from .htaccess file and php.ini file (requires root access from CLI) too. How much you can increase depends on your host. The beast practice is to keep php.ini more that the set for WP.

    Elegant Themes is known for being heavy. You can read the comments here to know the practical usability of ET :

    http://premium.wpmudev.org/forums/topic/recommended-professional-theme-providers

  3. khlucey
    Member
    Posted 1 year ago #

    I am not sure what your instructions are even telling me. I can't get into the wordpress file any more because I just get the "Fatal Error..."

  4. govpatel
    Member
    Posted 1 year ago #

    some host restricts you from increasing memory then you will need ask your host to do it for you.

  5. khlucey
    Member
    Posted 1 year ago #

    My host sent me back to wordpress. They say it is a wordpress issue. The host is Network Solutions.

  6. govpatel
    Member
    Posted 1 year ago #

    if you do not have enough then it is server issue there not much you can do if they have redistricted from increasing memory.

    You can try this steps if they works

    1. Try adding this line to your wp-config.php file:
    define(‘WP_MEMORY_LIMIT’, ’128M’);

    If this does not work you will need log in ftp client or server and find php.ini file in root and edit the file.

    2. If you have access to your PHP.ini file, change the line in PHP.ini
    If your line shows 32M try 128M:
    memory_limit = 128M ; Maximum amount of memory a script may consume (128MB)

    3. If you don’t have access to PHP.ini try adding this to an .htaccess file:
    php_value memory_limit 128M

  7. khlucey
    Member
    Posted 1 year ago #

    I need someone to take a few steps back with these suggestions. I am not understanding exactly what you are telling me.

    At this point, I cannot even get into my admin site because it won't let me in - I get the "Fatal Error" message if I try to login to my /wp-admin/ or the /wp-login/php pages.

    So how do I:
    1. get access to the wp-config.php file or
    log in ftp client or derves and find php.ini finle in root (what does that mean?)

    2. how do I get access to the PHP.ini file?

    3. what is the .htaccess file: ?

  8. govpatel
    Member
    Posted 1 year ago #

    Using Ftp

  9. Abhishek Ghosh
    Member
    Posted 1 year ago #

    govpatel is fully right in both posts.

    I am not sure what your instructions are even telling me.

    Ping that support with reference of this forum url.

    For self hosted WordPress, you actually need to know the small things. All starts from zero, gradually learns. Another tip is, for anything you can not understand, use two resources :

    1. Search in the wordpress.org search box (right top corner) with the main phrase (key phrase), likeincrease php memoryin your case. It often happen, a member posted the thing in details few years ago.
    2. Search in YouTube with that key phrase. You will get a visual idea.

    By the way, was the default WordPress theme was working ? If so, you can try other working theme (there are thousands of quite good themes), if you fail to fix the issue for now.

  10. khlucey
    Member
    Posted 1 year ago #

    the theme that I had before was working fine. I had not even switched over to the new theme, just was uploading it, when I got the error message. Now I can't even get into the /wp-admin site -so it is no longer an issue of installation or increasing memory, it is an issue of getting access to the admin site - I would delete the new theme if I could get onto the admin site and just continue to use my old theme.

    So is govpatel saying I can access the site using ftp?
    Could you be a bit more explicit?

  11. govpatel
    Member
    Posted 1 year ago #

    you trying to preview the theme triggered the memmory problem as you do have enough memory

    You will get get access to wordpress files folders and to switch back to default theme so that you can access admin panel login ftp
    browse to wp-content/themes folder in themes folder you will see all your themes rename the one you uploaded or delete the folder.
    Try and log in

  12. Abhishek Ghosh
    Member
    Posted 1 year ago #

    1. get access to the wp-config.php file : FTP software like FileZlla like govpatel said.

    2. how do I get access to the PHP.ini file? : SSH / Telnet client. Requires root access. Location is variable. This command gives the location (For REHL or CentOS) :

    php -r "phpinfo();" | grep Configuration

    3. what is the .htaccess file: ? That is this -> http://en.wikipedia.org/wiki/Htaccess ; its a dot file located where your index.php, license.txt etc. files are. Its created while setting permalink structure to pretty urls.

    4. "it is an issue of getting access to the admin site - I would delete the new theme if I could get onto the admin site and just continue to use my old theme." delete the folder. Its inside wp content / themes. (Edit : govpatel wrote while I was writing)

    You can watch this video for FTP thing :

    http://www.wpbeginner.com/beginners-guide/how-to-use-ftp-to-upload-files-to-wordpress-for-beginners/

    or this :

    http://www.youtube.com/watch?v=80rc8Ky__bs

    Always test new themes on your local computer installation.

  13. khlucey
    Member
    Posted 1 year ago #

    I am more confused now.
    Can you just say what I need to do get access to the wp-admin/ so I can delete the new theme?
    I understand that you two are quite knowledgeable about what you are doing, but even when you say to view the videos or google the answers, it is not leading me to understand what I need to do in this particular situation.

  14. govpatel
    Member
    Posted 1 year ago #

    Do have a ftp program installed on your computer like Filezilla if not then you can log in network solution account and browse to where you installed wordpress
    You should see three folders and some wp- files
    open wp-content folder
    open themes folder
    in there you should have theme you uploaded
    delete that folder
    now when you try login wordpress wordpress will force the default theme to open.

  15. khlucey
    Member
    Posted 1 year ago #

    thank you =
    I was able to go in through Network Solutions and manage the files that way.
    After some glitch because their file manager wouldn't open in Chrome - but once I figured that out, I was able to increase using the php.uni

    Thanks for your help

  16. govpatel
    Member
    Posted 1 year ago #

    You are welcome

Topic Closed

This topic has been closed to new replies.

About this Topic