WordPress.org

Ready to get started?Download WordPress

Forums

Install trouble, please help, errors listed below (2 posts)

  1. sambkk
    Member
    Posted 7 years ago #

    Hi there
    I tried to do my first WP installation. Didnt work, even the available instructions were good and plenty were available.

    What I have done so far:
    registered domain
    set up a hosting account
    created a database
    uploaded files (twice , 1st to subdirectory, once that pancaked, directly to root)

    I keep getting the folllowing error msgs when I go to url
    http://www.birchbolete.com/wp-admin/install.php

    errors listed:

    Warning: Unknown(): open_basedir restriction in effect. File(/home/tatti/public_html/wp-admin/install.php) is not within the allowed path(s): (/home/wwwbirc:/usr/lib/php:/usr/local/lib/php:/tmp) in Unknown on line 0

    Warning: Unknown(/home/tatti/public_html/wp-admin/install.php): failed to open stream: Operation not permitted in Unknown on line 0

    Warning: Unknown(): open_basedir restriction in effect. File(/home/tatti/public_html/wp-admin/install.php) is not within the allowed path(s): (/home/wwwbirc:/usr/lib/php:/usr/local/lib/php:/tmp) in Unknown on line 0

    Warning: Unknown(/home/tatti/public_html/wp-admin/install.php): failed to open stream: Operation not permitted in Unknown on line 0

    Warning: (null)() [function.include]: Failed opening '/home/tatti/public_html/wp-admin/install.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in Unknown on line 0

    my wp-confiog.php looks like this:
    <?php
    // ** MySQL settings ** //
    define('DB_NAME', 'tatti_tiamaria'); // The name of the database
    define('DB_USER', 'tatti_tiko'); // Your MySQL username
    define('DB_PASSWORD', 'tikojapiki'); // ...and password
    define('DB_HOST', 'localhost'); // 99% chance you won't need to change this value
    define('DB_CHARSET', 'utf8');
    define('DB_COLLATE', '');

    // You can have multiple installations in one database if you give each a unique prefix
    $table_prefix = 'wp_'; // Only numbers, letters, and underscores please!

    // Change this to localize WordPress. A corresponding MO file for the
    // chosen language must be installed to wp-content/languages.
    // For example, install de.mo to wp-content/languages and set WPLANG to 'de'
    // to enable German language support.
    define ('WPLANG', '');

    /* That's all, stop editing! Happy blogging. */

    define('ABSPATH', dirname(__FILE__).'/');
    require_once(ABSPATH.'wp-settings.php');
    ?>

    my database (from cpanel) info looks like this:
    Current Databases:
    tatti_tiamaria

    Users in tiamaria
    tatti_tiko (Privileges: ALL PRIVILEGES)

    Connection Strings
    Perl $dbh = DBI->connect("DBI:mysql:tatti_tiamaria:localhost","tatti_tiko","<PASSWORD HERE>");
    PHP $dbh=mysql_connect ("localhost", "tatti_tiko", "<PASSWORD HERE>") or die ('I cannot connect to the database because: ' . mysql_error());
    mysql_select_db ("tatti_tiamaria");

    Any ideas on where to start with this mess?
    I recently did a site with joomla. Joomla had a .php file you could upload and run, to check all files were present, any similar diagnostics tools available for wordpresss.

    Please help I am itching to start blogging.

    thanks

    sami

  2. sambkk
    Member
    Posted 7 years ago #

    hi
    I checked my DB via php-Myadmin and no tables had been creqated at all, so apparently the install scripts crashed straight away.

    Also
    I have installed wordpress2.2 in folder www and then removed it and tried it at public_html, both gave the same errors.
    Normally every site needs index.html file at www folder on this server.
    server is operating on linux and php version 4.4.7, mysql is 4.1.22-standard and apache is 1.3.37 (Unix)

    hope someone can help with this,
    thanks to all in advance.

    Sami

Topic Closed

This topic has been closed to new replies.

About this Topic