WordPress.org

Ready to get started?Download WordPress

Forums

Transfer second wordpress site to domain.com/secondsite (8 posts)

  1. JaanMatti
    Member
    Posted 1 year ago #

    Hello,

    I have a small WP-based e-store, that has two languages. Technically, the page has two different WP installs for two different languages - so the english version sits on eng.domain.com

    Is there a way I can transfer that WP install to domain.com/eng ?

    Thank You,
    Jaan-Matti

  2. WPProHelp
    Member
    Posted 1 year ago #

    Yes it is possible. Refer to the following document: http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory

  3. JaanMatti
    Member
    Posted 1 year ago #

    Thank You for the link. I have a question about it though - the codex tells me to move my WP install to domain.com/eng , by changing the site URL, wordpress URL and by "copying the index.php and htaccess to the root folder". But I already have an index.php and htacess file in the root folder, because the root has its own WP install (www.wordpress-site.com/wp-site-in-english) Should I somehow merge the two index.php files?

  4. WPProHelp
    Member
    Posted 1 year ago #

    By root folder the documentation means the root folder of the new installation, in your case the eng directory.

  5. JaanMatti
    Member
    Posted 1 year ago #

    Thanks for the answer. But I already have the index.php and htaccess in the /eng directory, because they are in the WP folder by default.

  6. JaanMatti
    Member
    Posted 1 year ago #

    I guess my problem right now is that I have successfully transferred the site to /eng, but the permalinks are messed up. When I click on the links in the menu, the page isnt there. It's like somehow the permalinks havent updated.

  7. WPProHelp
    Member
    Posted 1 year ago #

    Hi,

    Try:

    1. disabling and re-enabling the permalinks (in case something is wrong with the htaccess or so)

    2. Give us the URL of your website so we can see what is exactly happening.

  8. JaanMatti
    Member
    Posted 1 year ago #

    Hi,

    Thanks, by trying to disable the permalink settings I noticed, that on the /en install, my .htaccess file wasnt writable, so that was the problem :)

    Thanks again,
    Jaan-Matti

Topic Closed

This topic has been closed to new replies.

About this Topic