WordPress.org

Ready to get started?Download WordPress

Forums

Install on shared mySQL database (Aplus.net SoloXR) (4 posts)

  1. gsiebengartner
    Member
    Posted 7 years ago #

    Hello,

    I recently installed WordPress on my Aplus.net-hosted website. I have their SoloXR package, which only provides shared mySQL database access.

    That means that I can't choose the name of my DB, nor can I add users or modify permissions. However, I believe that some people have successfully installed WordPress on SoloXR accounts.

    Can anyone tell me what's going wrong? The error I get is "Error establishing a database connection", which you can see here: http://blog.siebengartner.com.

    My wp-config settings are:
    // ** MySQL settings ** //
    define('DB_NAME', 'geoffs'); // The name of the database
    define('DB_USER', 'geoffs'); // Your MySQL username
    define('DB_PASSWORD', '*******'); // ...and password
    define('localhost', 'localhost'); // 99% chance you won't need to change this value

    I've also tried replacing localhost with the actual name of my SQL server, which is pro7.abac.com, but that gets the same error.

    Thanks for your help.

  2. whooami
    Member
    Posted 7 years ago #

    that last line is wrong.
    define('localhost', 'localhost'); // 99% chance you won't need to change this value

    ought to be:

    define('DB_HOST', 'localhost'); // 99% chance you won't need to change this value

    you edited both values, and have removed the DB_HOST variable.

  3. gsiebengartner
    Member
    Posted 7 years ago #

    Brilliant! Thank you.

  4. whooami
    Member
    Posted 7 years ago #

    You're welcome :)

Topic Closed

This topic has been closed to new replies.

About this Topic