WordPress.org

Ready to get started?Download WordPress

Forums

Install on Linux system (28 posts)

  1. linuxlastslonger
    Member
    Posted 9 years ago #

    okay.... i'm new at this and with using web-based applications. so bear(sp?) with me. here is what i did (line for line):
    wget http://wordpress.org/latest.tar.gz
    tar -xzvf latest.tar.gz
    mv wordpress blueguppie.com
    cd blueguppie.com
    chmod +x *
    chmod wp-admin
    chmod +x *
    cd ..
    mv wp-config-sample.php wp-config.php
    vi wp-config.php (set to my param's for mysqld)
    i then browsed to http://www.blueguppie.com/ and got a blank page. i pointed it to blueguppie.com/wp-admin/install.php and still got nothing but a blank screen. i can view the readme.html, though. also, when i run
    php index.php
    or
    php wp-admin/install.php
    from the command line, here is what's returned:
    Content-type: text/html
    X-Powered-By: PHP/4.3.2
    please help!!!!
    thanks.
    - linuxlastslonger -

  2. skippy
    Member
    Posted 9 years ago #

    Can you check your web server's error log for any relevant output?

  3. linuxlastslonger
    Member
    Posted 9 years ago #

    also, you may reach me via ICQ. here is my number: 43655191
    thanks.
    -linuxlastslonger-

  4. linuxlastslonger
    Member
    Posted 9 years ago #

    here is what's in my error_log in /var/log/httpd
    [Tue Aug 24 14:52:55 2004] [notice] caught SIGTERM, shutting down
    [Tue Aug 24 14:52:56 2004] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
    [Tue Aug 24 14:52:58 2004] [notice] Digest: generating secret for digest authentication ...
    [Tue Aug 24 14:52:58 2004] [notice] Digest: done
    [Tue Aug 24 14:52:59 2004] [notice] Apache/2.0.46 (Red Hat) configured -- resuming normal operations

  5. skippy
    Member
    Posted 9 years ago #

    It's not clear what directory you started in. Can you provide a little more information about your setup? Is the blueguppie.com directory configured as the document root for your website?

  6. Matt Mullenweg
    Troublemaker
    Posted 9 years ago #

    What version of PHP are you trying this with?

  7. linuxlastslonger
    Member
    Posted 9 years ago #

    do'h, i forgot to post my version numbers:
    php: php-4.3.2-8.ent
    mysql: mysql-3.23.58-1.9
    apache: httpd-2.0.46-25.ent

  8. linuxlastslonger
    Member
    Posted 9 years ago #

    blueguppie.com is the DocumentRoot for the site. it's under /var/www.

  9. linuxlastslonger
    Member
    Posted 9 years ago #

    i don't think it matters, but so you have a better idea of what GNU/Linux environment i'm using; i have the RedHat Enterprise Linux WS 3 distrobution.
    thanks.
    -linuxlastslonger-

  10. linuxlastslonger
    Member
    Posted 9 years ago #

    nope, no errors. you can confirm that the info.php works by going to:
    http://www.blueguppie.com/info.php
    thanks.
    -linuxlastslonger-

  11. skippy
    Member
    Posted 9 years ago #

    Okay. Let's try from the beginning. Can you delete the current contents of blueguppie.com, and the re-extract the files?
    MySQL is running, yes? You've created a database already, yes?
    cd /var/www/blueguppie.com
    tar zxvf /tmp/latest.tar.gz
    mv wordpress/* .
    rmdir wordpress
    chmod -R go+rx ./*
    cp wp-config-sample.php wp-config.php
    vi wp-config.php

  12. linuxlastslonger
    Member
    Posted 9 years ago #

    yes, mysqld is running and i've already created a database named wordpress. i created a user named matthew with unlimited access rights to the database.
    thanks
    -linuxlastslonger-

  13. linuxlastslonger
    Member
    Posted 9 years ago #

    okay, did what you said, line-by-line, and it still acts the same. :-(
    any other suggestions?
    -linuxlastslonger-

  14. carthik
    Member
    Posted 9 years ago #

    the chmods are not neccesary.
    I tried the same steps you did, on my server, and it worked fine, without the chmods.
    You could try that.
    Try accessing /wordpress/ immediately after extracting, without editing anything. you should get a page that say "wp-config.php could not be found" or some such message that asks you to create the wp-config.php file. If you see that then that's something to start with, at least.

  15. linuxlastslonger
    Member
    Posted 9 years ago #

    i do get that even if it is not initially in the wordpress directory after extraction.
    -linuxlastslonger-

  16. linuxlastslonger
    Member
    Posted 9 years ago #

    if i click the link for it to automatically configure/create the wp-config.php, it tells me it doesn't have permission. does that help any?
    -linuxlastslonger-

  17. carthik
    Member
    Posted 9 years ago #

    Hi,
    Do not use the automatic creator. If you can see the message, then, after editing wp-config.php you should be able to install wordpress. However, since that does not seem to have worked, try putting wrong info in wp-config.php just to see if there is "cannot connect to database" error. If you see that, then try correcting the wp-config.php and see what happens. Just so you can find where exactly the problem lies.

  18. skippy
    Member
    Posted 9 years ago #

    Try also cranking up the verbosity of error logging in php.ini. I'd suggest E_ALL for the time being, so that all warnings and errors get logged. After you get this worked out, you can lower it.

  19. linuxlastslonger
    Member
    Posted 9 years ago #

    ok, thanks. i'll try these tests and let you know the results.

  20. linuxlastslonger
    Member
    Posted 9 years ago #

    nope, same thing. blank screen when i enter the wrong configuration changes into wp-config.php, and no errors are outputed with the E_ALL option.

  21. linuxlastslonger
    Member
    Posted 9 years ago #

    nope, same thing. blank screen when i enter the wrong configuration changes into wp-config.php, and no errors are outputed with the E_ALL option.

  22. carthik
    Member
    Posted 9 years ago #

    The following thread has a few solutions to your problems, mostly to do with php and mysql not working together well because of some options being set wrongly:
    http://wordpress.org/support/2/9550
    Please read that and try out the solutions suggested.

  23. linuxlastslonger
    Member
    Posted 9 years ago #

    thanks... i'll let update as needed.
    -linuxlastslonger-

  24. linuxlastslonger
    Member
    Posted 9 years ago #

    okay, here's what i did:
    because there was no php-mysql package for RH Enterprise, i had to uninstall httpd, php, and aspell. i then install apr, httpd, php (and the accompanying modules), and aspell for rh9 beta. now i don't get a blank page. but, now i get a "Cannot connect to Database" error. i've checked my settings and they are correct. any other suggestions?
    -linuxlastslonger-

  25. carthik
    Member
    Posted 9 years ago #

    Oh man! so close!
    Well, I must imagine it should be something about wp-config.php
    Can you try connecting to the database in another script, using the same details as in WP-Config?

  26. linuxlastslonger
    Member
    Posted 9 years ago #

    yep. i've tried running wp-admin/install.php and i get the same output.

  27. linuxlastslonger
    Member
    Posted 9 years ago #

    okay... here's what i did wrong...... I FORGOT TO CHECK USER PERMISSIONS AFTER I GOT PHP-MYSQL MOD INSTALLED!
    d'oh!!!! :-)
    thanks for your help guys/gals!!!!!!!
    -linuxlastslonger-

  28. carthik
    Member
    Posted 9 years ago #

    Great! Good to know it works now.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.