WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Install OK, but only blank page showing (32 posts)

  1. inging
    Member
    Posted 1 year ago #

    Just installed wordpress (latest version but it doesnt say which number).

    I received this email from wordpress:

    Your new WordPress site has been successfully set up at:

    http://xx.no/wordpress

    You can log in to the administrator account with the following information:
    Username: xx
    Password: The password you chose during the install.

    But I can´t log in...this site contains nothing- it´s simply a blank page. I might have done something wrong during the installation/upload in FTP,as Im new to this, but I did follow instructions (from my webhost) quite carefully.

    Des anybody know how I can fix this?

  2. WPProHelp
    Member
    Posted 1 year ago #

    If that is the domain of your website it seems that the DNS is not configured correctly.

    So first sort out the DNS

  3. inging
    Member
    Posted 1 year ago #

    Hi,

    my domain name isnt xx I just wrote that as an example. Point is its blank.

    Could yu tell me what DNS stands for and where do I sort it out?

  4. WPProHelp
    Member
    Posted 1 year ago #

    Then DNS has got nothing to do with this issue. I thought that is your Domain name.

    Can you give us the URL of your website so we have a look and let you know what might be wrong?

    Also did you just do an upgrade or you just installed a new WordPress install?

  5. inging
    Member
    Posted 1 year ago #

    I did a completely new install. This is the first time I did this.

    the correct URL is http://varangerworkshop.no/wordpress

    [No bumping. If it's that urgent, consider hiring someone.]

  6. esmi
    Forum Moderator
    Posted 1 year ago #

  7. inging
    Member
    Posted 1 year ago #

    Thanks! It seems to be working now, Ive managed to get into wordpress and install the template from Photocrati. How do I make the main page visible for others? (www.varangerworkshop.no is still blank)

  8. pwhstacy
    Member
    Posted 1 year ago #

    Hi.

    It seems that you have install wordpress under your wordpress directory. so you will need to install it under your respective folder.
    e.g public_html

  9. inging
    Member
    Posted 1 year ago #

    OK, not sure that I understand you correctly. I have the wordpress folder installed in the www-folder. That seems to be the only folder there?

    Oh and sorry for bumping. I actually did try to hire someone...

  10. esmi
    Forum Moderator
    Posted 1 year ago #

  11. ndoremieux
    Member
    Posted 1 year ago #

    You have installed wordpress on the folder /wordpress so the url of your website is http://varangerworkshop.no/wordpress you do not have wordpress installed on the folder http://varangerworkshop.no. You need to install wordpress directly under public_html. Let me know if that's not clear,
    Nathalie

  12. esmi
    Forum Moderator
    Posted 1 year ago #

    A re-install is not necessary in this situation. Please see the link I posted above.

  13. inging
    Member
    Posted 1 year ago #

    Thanks for good advice both of you. Trying to do as the link says now. :)

  14. inging
    Member
    Posted 1 year ago #

    I cant seem to find the .htaccess anywhere, even after showing hidden files.

    Does anybody know what "using your directory name for the WordPress core files" means? What is my directory name- the domain?

  15. esmi
    Forum Moderator
    Posted 1 year ago #

    Are you using custom or default permalinks?

  16. inging
    Member
    Posted 1 year ago #

    I don´t know. Where can I find out?

  17. esmi
    Forum Moderator
    Posted 1 year ago #

    Settings -> Permalinks.

  18. inging
    Member
    Posted 1 year ago #

    Default.

  19. esmi
    Forum Moderator
    Posted 1 year ago #

    In that case, you won't have an .htaccess file in your root WP folder yet, so you can just skip that bit.

  20. inging
    Member
    Posted 1 year ago #

    hooray!

    So Ive done everything except update my permalink structure (step no. 8). And apparently somethings wrong as the site is still blank.

  21. esmi
    Forum Moderator
    Posted 1 year ago #

    I can only suggest that you undo your changes and review all of the steps again.

  22. inging
    Member
    Posted 1 year ago #

    Oh dear.

    I believe the problem is that I can´t copy files but have to move them, as it says I should NOT do. Plus that I dont understand the structure of the FTP program (Filezilla) at all..

  23. esmi
    Forum Moderator
    Posted 1 year ago #

    You MUST copy the files. Download the originals from the wordpress sub-folder, amend them locally and then upload the amended copies to the root domain folder.

  24. inging
    Member
    Posted 1 year ago #

    OK, I have now copied and still not working. Do you know what they mean by directory name in step no. 6:

    Change the following and save the file. Change the line that says:
    require('./wp-blog-header.php');
    to the following, using your directory name for the WordPress core files:
    require('./wordpress/wp-blog-header.php');

    Should I write exactly what it says in this example or something else?

  25. ndoremieux
    Member
    Posted 1 year ago #

    yes in your case since wordpress is installed in a folder called wordpress you need to copy this exact same folder:
    require('./wordpress/wp-blog-header.php');

    Have you fixed your problem? sounds like this is marked as resolved.

    nathalie

  26. inging
    Member
    Posted 1 year ago #

    OK, that´s what I did, with no success.

    Unfortunately problem is not resolved. Main page still blank...

    http://varangerworkshop.no/wordpress/ looks like http://www.varangerworkshop.no/ should look...

  27. inging
    Member
    Posted 1 year ago #

    I tried deleting the whole shebang and reupload it instead. But I dont have a public_html-thing. Any tips?

  28. inging
    Member
    Posted 1 year ago #

    I uploaded a screenshot of my FTP here.

    http://farm9.staticflickr.com/8461/8019666301_51af0e9c90_o.png

    So I deleted the folder off the web and now its just on my desktop. Maybe someone can tell me where exactly to upload the folder? I´m sorry but I really don´t get it. :)

  29. ndoremieux
    Member
    Posted 1 year ago #

    I still think that the easiest way to do this is to uninstall WordPress and install it in the correct folder at the root of your home directory so that they url will be http://varangerworkshop.no
    Since your webhost gave you instructions in the first place I suggest you go back to them and ask them in which folder you need to install wordpress in order to have the url http://varangerworkshop.no

    Nathalie

  30. inging
    Member
    Posted 1 year ago #

    OK, thanks for your help anyway. Funny it´s this complicated to install wordpress. Ive always been told it´s really easy to use wordpress and that´s why I chose it in the first place.

Topic Closed

This topic has been closed to new replies.

About this Topic