WordPress.org

Ready to get started?Download WordPress

Forums

Jetpack by WordPress.com
install of jetpack (7 posts)

  1. PB21
    Member
    Posted 1 year ago #

    I have installed but everytime i go to the dashboard it says jetpack is almost ready and if i click connect to wordpress.com it says register_http_request_failed ssl certificate problem self signed certificate in chain.

    I am hosting the site on my synology ds411+ but not sure how to eliminate this error. please could someone assist.

    http://wordpress.org/extend/plugins/jetpack/

  2. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    The problem might be caused to your version of PHP. Could you check and make sure that your server uses PHP version 5.2.4 or greater?

    If that doesn't help, can you please try installing the Jetpack Compatibility Plugin so we can see some additional information from your site?

    1) Download the plugin from http://plugins.svn.wordpress.org/jetpack/branches/jetpack-compatibility-test.zip
    2) Upload the plugin to your site via Dashboard -> Plugins -> Add New.
    3) Activate the plugin and go to Plugins -> Jetpack Compatibility Test.
    4) Click the "Select All" button.
    5) Send us the test results via this contact form:
    http://en.support.wordpress.com/contact/?jetpack=needs-service

    Thanks!

  3. roitit
    Member
    Posted 1 year ago #

    Here is my compatibility results.

    TEST: Integer Tests
    Array
    (
    [$value = "d0000000";] => (string) d0000000
    [$value = hexdec( $value );] => (double) 3489660928
    [$value = abs( $value );] => (double) 3489660928
    [$min = 0;] => (integer) 0
    [$max = 61;] => (integer) 61
    [4294967295 + 1] => (double) 4294967296
    [$value / (4294967295 + 1)] => (double) 0.8125
    [$max - $min + 1] => (integer) 62
    [($max - $min + 1) * ($value / (4294967295 + 1))] => (double) 50.375
    [$out = $min + (($max - $min + 1) * ($value / (4294967295 + 1)));] => (double) 50.375
    [$out = intval( $out );] => (integer) 50
    [$out = abs( $out );] => (integer) 50
    )

    TEST: wp_generate_password()
    Array
    (
    [0] => 1 -> 1:x
    [1] => 5 -> 5:SldxI
    [2] => 10 -> 10:sLofqbhzRs
    [3] => 16 -> 16:xScOTVL6nVGhUmgX
    [4] => 32 -> 32:YZo0ISWmydCZFUSWDTqscHchhHsjx5QE
    [5] => 32 -> 32:HSlRiBlMDeic6OFXHAhJ15raxuoo71m8
    [random_password] => abcdefghijklmnopqrstuvwxyzABCDEFGHIJKLMNOPQRSTUVWXYZ0123456789
    [steps] => Array
    (
    [0] => 15 -> p
    [1] => 27 -> B
    [2] => 24 -> y
    [3] => 24 -> y
    [4] => 4 -> e
    [5] => 15 -> p
    [6] => 35 -> J
    [7] => 9 -> j
    [8] => 36 -> K
    [9] => 3 -> d
    [10] => 54 -> 2
    [11] => 4 -> e
    [12] => 61 -> 9
    [13] => 44 -> S
    [14] => 45 -> T
    [15] => 3 -> d
    [16] => 39 -> N
    [17] => 43 -> R
    [18] => 56 -> 4
    [19] => 10 -> k
    [20] => 59 -> 7
    [21] => 9 -> j
    [22] => 39 -> N
    [23] => 44 -> S
    [24] => 17 -> r
    [25] => 50 -> Y
    [26] => 22 -> w
    [27] => 8 -> i
    [28] => 51 -> Z
    [29] => 24 -> y
    [30] => 31 -> F
    [31] => 9 -> j
    )

    [ReflectionFunction] =>
    /**
    * Generates a random password drawn from the defined set of characters.
    *
    * @since 2.5
    *
    * @param int $length The length of password to generate
    * @param bool $special_chars Whether to include standard special characters. Default true.
    * @param bool $extra_special_chars Whether to include other special characters. Used when
    * generating secret keys and salts. Default false.
    * @return string The random password
    **/
    Function [ <user> function wp_generate_password ] {
    @@ D:\hshome\go5star\roitit.com\wordpress\wp-includes\pluggable.php 1485 - 1499

    - Parameters [3] {
    Parameter #0 [ <optional> $length = 12 ]
    Parameter #1 [ <optional> $special_chars = true ]
    Parameter #2 [ <optional> $extra_special_chars = false ]
    }
    }

    )

    TEST: wp_rand()
    Array
    (
    [0] => '23f1cac34a34dd2ba4a8294b66acce23ae1aca1b4c507231e7908c57a8513c81be26ae3bb11567222a3d5291e9f2427b'
    [1] => 8:b7242f9e1925d3a22276511bb3ea62eb18c3158a75c8097e132705c4b1aca1ea32ecca66b4928a4ab2dd43a4
    [2] => 17:b7242f9e1925d3a22276511bb3ea62eb18c3158a75c8097e132705c4b1aca1ea32ecca66b4928a4a
    [3] => 39:b7242f9e1925d3a22276511bb3ea62eb18c3158a75c8097e132705c4b1aca1ea32ecca66
    [4] => 24:b7242f9e1925d3a22276511bb3ea62eb18c3158a75c8097e132705c4b1aca1ea
    [5] => 42:b7242f9e1925d3a22276511bb3ea62eb18c3158a75c8097e132705c4
    [6] => 18:b7242f9e1925d3a22276511bb3ea62eb18c3158a75c8097e
    [7] => 56:b7242f9e1925d3a22276511bb3ea62eb18c3158a
    [8] => 40:b7242f9e1925d3a22276511bb3ea62eb
    [9] => 46:b7242f9e1925d3a22276511b
    [10] => 42:b7242f9e1925d3a2
    [11] => 10:b7242f9e
    [12] => 56:
    [13] => 46:b5982f7cd14ef509bde61bc788fee5ac6a7a794766749a5dfec2e90ca00bc153cf7d2f43a63ab9226dd3529ddbc1c161a92c7930
    [14] => 0:b5982f7cd14ef509bde61bc788fee5ac6a7a794766749a5dfec2e90ca00bc153cf7d2f43a63ab9226dd3529ddbc1c161
    [15] => 5:b5982f7cd14ef509bde61bc788fee5ac6a7a794766749a5dfec2e90ca00bc153cf7d2f43a63ab9226dd3529d
    [16] => 52:b5982f7cd14ef509bde61bc788fee5ac6a7a794766749a5dfec2e90ca00bc153cf7d2f43a63ab922
    [17] => 8:b5982f7cd14ef509bde61bc788fee5ac6a7a794766749a5dfec2e90ca00bc153cf7d2f43
    [18] => 12:b5982f7cd14ef509bde61bc788fee5ac6a7a794766749a5dfec2e90ca00bc153
    [19] => 12:b5982f7cd14ef509bde61bc788fee5ac6a7a794766749a5dfec2e90c
    [20] => 46:b5982f7cd14ef509bde61bc788fee5ac6a7a794766749a5d
    [MIN] => 0
    [MAX] => 56
    [ReflectionFunction] =>
    /**
    * Generates a random number
    *
    * @since 2.6.2
    *
    * @param int $min Lower limit for the generated number
    * @param int $max Upper limit for the generated number
    * @return int A random number between min and max
    */
    Function [ <user> function wp_rand ] {
    @@ D:\hshome\go5star\roitit.com\wordpress\wp-includes\pluggable.php 1512 - 1546

    - Parameters [2] {
    Parameter #0 [ <optional> $min = 0 ]
    Parameter #1 [ <optional> $max = 0 ]
    }
    }

    )

    TEST: HTTP Connection
    Array
    (
    [headers] => Array
    (
    [server] => nginx
    [date] => Fri, 05 Apr 2013 04:57:35 GMT
    [content-type] => text/plain;charset=utf-8
    [connection] => close
    [vary] => Cookie
    [x-pingback] => http://jetpack.wordpress.com/xmlrpc.php
    [expires] => Wed, 11 Jan 1984 05:00:00 GMT
    [cache-control] => no-cache, must-revalidate, max-age=60
    [pragma] => no-cache
    [x-hacker] => Jetpack Test
    )

    [body] => OK
    [response] => Array
    (
    [code] => 200
    [message] => OK
    )

    [cookies] => Array
    (
    )

    [filename] =>
    )

    TEST: HTTPS Connection
    WP_Error Object
    (
    [errors] => Array
    (
    [http_request_failed] => Array
    (
    [0] => SSL certificate problem: self signed certificate in certificate chain
    )

    )

    [error_data] => Array
    (
    )

    )

    TEST: Self Connection
    Array
    (
    [headers] => Array
    (
    [connection] => close
    [date] => Fri, 05 Apr 2013 04:57:37 GMT
    [content-length] => 42
    [content-type] => text/plain
    [server] => Microsoft-IIS/6.0
    [x-powered-by] => Array
    (
    [0] => ASP.NET
    [1] => PHP/5.3.20
    )

    )

    [body] => XML-RPC server accepts POST requests only.
    [response] => Array
    (
    [code] => 200
    [message] => OK
    )

    [cookies] => Array
    (
    )

    [filename] =>
    )

  4. roitit
    Member
    Posted 1 year ago #

    Same problem. SSL error

  5. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    TEST: HTTPS Connection
    WP_Error Object
    [0] => SSL certificate problem: self signed certificate in certificate chain

    It seems that your server is unable to make verified outgoing HTTPS requests to https://jetpack.wordpress.com/.

    I can't know for sure without knowing your site URL, but if you use Windows on your home server, cURL's SSL certificate bundle might be either missing or out of date on your server.

    Could you try to make the necessary updates on your site, and let me know if it helps?

  6. roitit
    Member
    Posted 1 year ago #

    site url http://www.roitit.com I use ixwebhosting

  7. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    Thanks!

    Something seems to be wrong with your site's SSL configuration: you can see the problem by trying to access https://www.roitit.com/

    You attempted to reach http://www.roitit.com, but instead you actually reached a server identifying itself as *.c8.ixwebhosting.com. This may be caused by a misconfiguration on the server or by something more serious

    Could you contact your hosting provider, and ask them to remove the SSL certificate from your site?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags