WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Inserting an URL in 2.1 Ella does not work (WYSIWYG) (26 posts)

  1. Sajonara
    Member
    Posted 7 years ago #

    I recently upgraded to the 2.1 FINAL. Everthing went fine, I thought. I wrote a new article, I clicked on the "insert an URL" button in the WYSIWYG-editor and some silly ajax-window came up, instead of the popup-javascript-window that 2.0.7 and all versions before used. All of a sudden the buttons for "insert" and "cancel" are not SHOWN in that ajax-window. I click on the mousewheel and scroll down the window. Happy to find the buttons at the very end of a window that seems not to be dimensioned the right way. But guess what? Clicking on the buttons does not help. So the window stucks, cause when I click on the "x" in the right corner to close the small, shiny, funky ajax-window nothing happens. I have to click the reload button. Nice that the autosave prevented losing the whole article.

    But when I try it again and again everytime happens the same. The buttons are not shown, the ajax-window gets stuck and I can hit reload. Guys and girls I am using Firefox in the newest version and I can't guess what's going wrong here, but I can guess that things like that shouldn't happen if a thing is named "final". Anyone can tell me which file I have to modify by hand for the ajax-window (insert url) will work properly?!

  2. dannyboy
    Member
    Posted 7 years ago #

    I've had the same problem, but with the insert image dialogue.

    I posted a thread about this earlier but it hasn't seemed to have received any replies.

  3. Sajonara
    Member
    Posted 7 years ago #

    Well at least we're two. :) Think we can just wait and perhaps have a cup of tea. Perhaps I shall get something to eat either.

    The frontend of course works fine, and plugins I am using seem to work properly...

  4. Sajonara
    Member
    Posted 7 years ago #

    Guess what... in the german forums I found a small hint. Another guy has the same problems. This is a "firefox" specific problem as it seems, and of course a problem concerning the java/ajax thing.

    Try to use your wp-admin from IE, Opera or another browser. When I use the IE7 or Opera the problem is no problem at all. This is strange form of irony I think for that a lot of WordPressusers are using Firefox... for it's free and not from Microsoft.

  5. moshu
    Member
    Posted 7 years ago #

    Is it FF2? Because my 1.5.0.9 FF works perfectly...

  6. Chris_K
    Member
    Posted 7 years ago #

    Works fine for me in FF 2.0.1 as well.

  7. Sajonara
    Member
    Posted 7 years ago #

    It's FF 2.0.0.1, german version. But I guess it might be something with Firefox and the Firefox Javaenvironment?!

  8. Chris_K
    Member
    Posted 7 years ago #

    Also check popup blockers (built-in and assorted toolbars).

  9. Sajonara
    Member
    Posted 7 years ago #

    Check this out: http://www.sajonara.de/?p=438

    The text is in german but look at the two screenshots. This is how the "insert URL"-window looks like in IE7 (first screeny) and Firefox (second one).

  10. Sajonara
    Member
    Posted 7 years ago #

    I have no toolbars in use, because I don't need them. ;) Hence this can't be the issue. I guess it has something to do with the Java environment for my Firefox... mh...

  11. Chris_K
    Member
    Posted 7 years ago #

    Say, I just checked in IE/Opera/FF. They all work, but... none of them have that "Class" option that shows up on your Firefox screenshot.

    Where's that coming from? Any interesting plugins still activated?

  12. Sajonara
    Member
    Posted 7 years ago #

    The "Class" Option just comes from the Advanced-WYSIWYG Plugin from Assaf Arkin... but I tried this out with the plugin activated and/or deactivated. No changes.

  13. Sajonara
    Member
    Posted 7 years ago #

    But you see that the "buttons" are not shown correctly, and the dimensions of the ajax-window are not alright at all? And of course when it comes up it breaks the whole thing. Cause I can not cancel it, nor can I insert a link... and I can not close the window either. I just upgraded the Java Runtime Environment in Firefox to the latest version but it did not change a thing.

  14. Sajonara
    Member
    Posted 7 years ago #

    It has something to do with firefox because in other browsers running on my system I can work with WordPress without a hassle. This is strange.

  15. foolswisdom
    Moderator
    Posted 7 years ago #

    Sajonara, you are basically complaining that you did not contribute by testing it prior to it being released. It is clear that you have great skill at reporting a problem -- that is what makes me sad and upset.

    About now the problem at hand. I have not yet been able to reproduce this, but there are a few other reports -- but not anything consistent or reproducible. Lets figure it out!

    You are running Firefox 2 on what OS? Screen shots so we all can compare? Anything in the browser's error console?

  16. foolswisdom
    Moderator
    Posted 7 years ago #

    Sajonara, my comment was based on the initial post. You are kicking butt now!

  17. Sajonara
    Member
    Posted 7 years ago #

    I am complaining that people have released a RC1 short time before... I slept some (were it two?) days over and wow... a final version was pulled out of the hat. And we were promised that next releases will come faster and faster. I can wait for releases as long as it takes. I have never contributed to beta testing, that's right, but I just have used "final" versions. And I have seen videogame industry and software companys recently producing faster and faster but buggyer and buggyer.
    I use my time for different things than software experiments, but I can contribute by spending money for the project. That's how I can contribute. I have no problem with this, I spent money for some plugin authors as well.

    I am running Firefox 2 on Windows XP. With now the recent 1.5.10 or Java Runtime Environment... switched off popup-blockers. I presented some screenshots at my homepage. How do I access the error console? ;)

  18. speechpoet
    Member
    Posted 7 years ago #

    I'm having the same problem in Firefox 2.0.0.1 on Mac OS X 10.4.8. The error console (menu: Tools / Error Console, Sajonara) reports multiple identical errors:

    Error: this.frame.tinyMCEPopup.restoreSelection is not a function
    Source File: http://www.robcottingham.ca/wp-includes/js/
    tinymce/tiny_mce_gzip.php?ver=20061113&
    theme=advanced&language=&
    plugins=inlinepopups%2Cautosave%2Cspellchecker%2C
    paste%2Cwordpress&lang=&index=0
    Line: 1082

    Hope that's helpful.

  19. erotelli
    Member
    Posted 7 years ago #

    Hi, same problem of Sayonara - I use windows Xp and browse with Firefox 2.0.1 (just upgraded for the problem) italian version and the TinyMce link doesn't work. The answer is this:

    this.frame.tinyMCEPopup.restoreSelection is not a function
    close()tiny_mce_gzip.php (line 1090)
    [Break on this error] this.frame['tinyMCEPopup'].restoreSelection();

    Before to allowed the pop up windows in the browser lot's of button doesn't appears, like the link. After, they apperar, but the link pop up doesn't work.

  20. momocat
    Member
    Posted 7 years ago #

    Fehler: this.frame.tinyMCEPopup.restoreSelection is not a function
    Quelldatei: http://umgebungsgedanken.momocat.de/wp-includes/js/tinymce/tiny_mce_gzip.php?ver=20061113&theme=advanced&language=de_de&plugins=inlinepopups%2Cautosave%2Cspellchecker%2Cpaste%2Cwordpress&lang=de_de&index=0
    Zeile: 1082

    german Firefox 2.0.0.1, on Windows 2000, WordPress 2.1

  21. Sajonara
    Member
    Posted 7 years ago #

    Try to change the Javascript Options as it is shown here:

    http://wordpress.org/support/topic/101716?replies=19#post-502785

    And of course update your Java runtime environment to the newest 1.5.10. This worked for me, I guess. Well... I did some other things as well but I can't imagine those have something to do with this. Please tell if it worked out for you.

  22. fl3x
    Member
    Posted 7 years ago #

    Hmm, it didn't work out for me. I checked the boxes, upgraded to java 1.5.10, made sure the sql-servers version is higher than 4.
    Right now I'm running out of ideas, how the problem can be solved.

  23. jillesvangurp
    Member
    Posted 7 years ago #

    Updating you java environment is not likely to be helpful since wordpress contains exactly 0 lines of java code. Javascript, despite the name, is completely unrelated to java.

  24. Sajonara
    Member
    Posted 7 years ago #

    Is anyone as well using the Advanced WYSIWYG plugin? I disabled it, for it does not work properly with 2.1 yet.

  25. hakre
    Member
    Posted 7 years ago #

    The Solution is simple: After the Update, close all browser Tabs in Firefox, navigate with the last open one to google homepage or about:blank and then clear the cache. Restart the Browser and everything works fine as expected.

    The Error is not Firefox related in general nor is it OS Releated. It occurs when the Browser uses an older javascript file that is incompatible with the one shipped with WordPress 2.1

  26. turmeric
    Member
    Posted 7 years ago #

    Thank you, Hakre! It works!!!

Topic Closed

This topic has been closed to new replies.

About this Topic