WordPress.org

Ready to get started?Download WordPress

Forums

inserted links default to wp-admin folder (4 posts)

  1. 123nathan
    Member
    Posted 6 years ago #

    I just upgraded to version 2.5 and, after scratching my head, I've found that when I insert a link to another page on my site, it seems to default to the wp-admin folder when I publish it. I use the default permalink structure (if that's related).

    For example, if I needed to make a link to a page, I would type this into the insert link window:
    index.php?page_id=275

    and it worked just fine until I upgraded to version 2.5. After doing that, if I type the same think into the insert link window, it is transformed to the following after saving or publishing the post:
    http://www.isaacandnathan.com/wp-admin/index.php?page_id=275

    Which causes the admin login page or the dashboard to display instead of the desired page or post.

    Am I doing something wrong or is there a setting I need to change? I really don't want to have to type my domain each time I make a link, and I didn't have to before I upgraded. Can someone help?

  2. buzz
    Member
    Posted 6 years ago #

    Yeah, it looks like absolute URLs are the way to go. Or see this topic:
    http://wordpress.org/support/topic/164301?replies=6
    (some hacks included)

  3. 123nathan
    Member
    Posted 6 years ago #

    Thanks! I figured that it had been addressed in another thread but I wasn't able to find it. Is there some way to get wordpress to stop putting the wp-admin part in there when forming the absolute url? I can type in ../folder every time but I'd rather not.

  4. buzz
    Member
    Posted 6 years ago #

    If you use an absolute address, it shouldn't reform it. If you have just a small number of addresses that you repeatedly link to, copy them to a text file for a quick copy and paste. Or try this plugin:

    http://wordpress.org/extend/plugins/admin-notes/

Topic Closed

This topic has been closed to new replies.

About this Topic