WordPress.org

Ready to get started?Download WordPress

Forums

JW Player for Flash & HTML5 Video
[resolved] INSERT JW PLAYER: Button is irresponsive (23 posts)

  1. proque
    Member
    Posted 1 year ago #

    HOW TO FIND THE BUG:

    when writing new post:
    1- INSERT MEDIA
    2- EXTERNAL MEDIA
    3- SPECIFY YOUTUBE URL
    4- JWPLAYWER FETCHES DATA CORRECTLY
    5- CLICK "INSERT JW PLAYER" BUTTON

    PROBLEM:

    The button is irresponsive. Nothing happens, nothing is inserted on the post and the "insert media" pop up does not even close.

    Please fix this ASAP. Thanks.

    http://wordpress.org/extend/plugins/jw-player-plugin-for-wordpress/

  2. JW Player
    Member
    Plugin Author

    Posted 1 year ago #

    Thanks, we will take a look at the issue.

  3. zollywood
    Member
    Posted 1 year ago #

    Am also experiencing the same problem,The button is irresponsive. Nothing happens, nothing is inserted on the post and the "insert media" pop up does not even close.How can I fix this , Thank you,

  4. liorgross
    Member
    Posted 1 year ago #

    I have the same issue. when looking at the console log I see this:

    Uncaught ReferenceError: wp is not defined

    at file media-upload.php line 340,

    it's the JS - "wp.media.post('send-attachment-to-editor', " ....

  5. JW Player
    Member
    Plugin Author

    Posted 1 year ago #

    Thanks, we will take a look at the issue.

  6. toddbenton
    Member
    Posted 1 year ago #

    I am having the same issue.

  7. toddbenton
    Member
    Posted 1 year ago #

    I am having the same issue too. The button is unresponsive.

  8. toddbenton
    Member
    Posted 1 year ago #

    I just figured out a workaround. I was able to create the shortcode by copying a previous shortcode and replacing the mediaid number: [jwplayer config="myplayer" mediaid="xxxx"]

    If you use firebug, you can find the mediaid after you have gone through the normal process and clicked the button. Even though the button is unresponsive, apparently it inserts the correct media id. I was able to find the media id in the javascript while I still had the insert media pop up still open.

    Hope this helps others...

  9. JW Player
    Member
    Plugin Author

    Posted 1 year ago #

    Thanks for sharing, glad you got it working.

  10. bergamot
    Member
    Posted 1 year ago #

    I'm also having the same issue. Please solve that ASAP cause it really makes the plugin unusable.

    Thanks in advance!

  11. JW Player
    Member
    Plugin Author

    Posted 1 year ago #

    We are going to have to fix this in a future version. It seems weird though, as it doesn't happen in our test blog.

  12. bergamot
    Member
    Posted 1 year ago #

    Well, you've got no issue on your blog, but there's many of us who has that issue. When do you plan to release a new version of the plugin?

  13. JW Player
    Member
    Plugin Author

    Posted 1 year ago #

    I don't have the exact ETA, sorry. We will have to debug the issue, replicate it, troubleshoot it, then release a fix. Our office has been closed for the holidays, so we will have to look into this when we return to work. Sorry for any inconvenience.

  14. drtanz
    Member
    Posted 1 year ago #

    Same problem here, might be due to changes in WP 3.5 ways of loading javascript.

  15. proque
    Member
    Posted 1 year ago #

    Lame support.

    This simple issue was posted 1 week ago... and all you did was "look at the issue", didn't even provide a temporary workaround. it had to be a user doing it. ( thanks Todd ).

    As a paying customer, I am disappointed.

  16. JW Player
    Member
    Plugin Author

    Posted 1 year ago #

    We are going to fix this, but we have been away. It looks like the work around for the time being is to insert the JW Player from the gallery grid overview, that one works, the other one (external media) is the one that is not responsive.

  17. JW Player
    Member
    Plugin Author

    Posted 1 year ago #

    We released an update that should have fixed this.

  18. proque
    Member
    Posted 1 year ago #

    Thanks!
    Update to 1.7.2 fixed the issue.

  19. JW Player
    Member
    Plugin Author

    Posted 1 year ago #

    Np!

  20. Jonathan
    Member
    Posted 1 year ago #

    Just ran into this problem again with the latest version of JW Player.

    I'm getting the same irresponsive "Insert with JW Player" button, not when trying to insert external media, but when trying to insert the JW Player from the gallery grid overview/insert media screen.

    Will try workaround as well.

  21. JW Player
    Member
    Plugin Author

    Posted 1 year ago #

    Can you provide a log in for us so we can see what might be happening here? - http://www.longtailvideo.com/contact-us

  22. nick2009
    Member
    Posted 1 year ago #

    Using: Version 2.1.1
    JW Player 6 Plugin for WordPress

    "Insert with JW Player" button wasn't working for me.

    Firebug was throwing an error about the select2 jquery plugin.

    select2 is not a function

    I think this was because for some reason the plugin files were being loaded before jquery. I had to create a custom.js file and load the plugins .js files *after* jquery.

  23. JW Player
    Member
    Plugin Author

    Posted 1 year ago #

    Interesting, thanks for passing thing along.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic