WordPress.org

Ready to get started?Download WordPress

Forums

Insert into post and use as thumbnail at same time (3 posts)

  1. TulsaWeb
    Member
    Posted 4 years ago #

    I don't quite know where to post this.

    I'm trying to use an image in a post and use that same image as the post thumbnail.

    I can get this to work fine, if I search for the image twice from the media folder (once for the insert and once for the thumbnail).

    It seems I can do both functions at the same time, but it doesn't take. I search for the image and choose 'Use as thumbnail' and the thumbnail appears to be chosen, then I choose "Insert into post" and publish the post. After publishing, the thumbnail field returns empty. I have to go get the image again.

    Is this intended, or have I broken something?

  2. esmi
    Theme Diva & Forum Moderator
    Posted 4 years ago #

    It's working as intended as far as I know. You need to do this as tow completely separate operations - eg:

    1. Upload image & insert in Post
    2. Click the 'Use as thumbnail' link and select image as the post thumb.

  3. Hillfoot
    Member
    Posted 3 years ago #

    I seem to be having much the same problem. However, in my case it is not possible to select "Thumbnail" because it is permanently greyed out.

    I cannot selct "Thumbnail" on first upload and insertion - nor can I select "Thumbnail" once the photo has been inserted as esmi suggests.

Topic Closed

This topic has been closed to new replies.

About this Topic