WordPress.org

Ready to get started?Download WordPress

Forums

"insert image into post" creates a blank screen (47 posts)

  1. popart
    Member
    Posted 5 years ago #

    I'm also having the problem with "Insert into Post" ... desperately searching for a solution for a site I'm building for a client.

    I've disabled/removed all plugins, and basically tried every fix I've found...

    Still not working. I'm getting the White Screen after clicking "Insert into Post". The image does upload to the server, but it doesn't get inserted into post. I just get stuck on the blank, white page.

    I really need to get this fixed asap.

  2. nflood
    Member
    Posted 5 years ago #

    I'm also having this problem on my site http://www.bedroompublishing.com

    I'm running WordPress 2.7 and commentLuv

    I just turned disabled commentLuv and I can now upload images again correctly : )

  3. sykon
    Member
    Posted 5 years ago #

    I was having the same problem too for the last several months. HERE'S THE SIMPLE SOLUTION!
    Completely erase the wp-admin folder and the wp-includes folder.
    Then upload a fresh wp-admin folder and a fresh wp-includes folder.
    This should work. I'm confident of it.

    What I was doing earlier I would simply overwrite the existing folders but the problem would still continue. so this time i decided to completely erase the folders and then upload fresh new ones in their place and it worked! It worked for me and I'm confident it will work for you too!

  4. sykon
    Member
    Posted 5 years ago #

    I also posted the solution on my blog. Good luck!

  5. Thomas Umstattd
    Member
    Posted 5 years ago #

    @conanh Thanks for posting the error. I have posted it to the support ticket.

    @sykon Thanks for posting your fix. As much as I wish I could say your fix worked for me I can't. I still have the white screen of death.

  6. Thomas Umstattd
    Member
    Posted 5 years ago #

    Please consider helping us trouble shoot it on support ticket #8806.

    http://trac.wordpress.org/ticket/8806

    The priority has been set to critical which is encouraging but no one has picked it up yet.

  7. popart
    Member
    Posted 5 years ago #

    For me, the problem was with my theme.
    I was using the WPRemix2 Theme. All I had to do was comment out the code calling for the remix advanced editor in functions.php. Once I did that, image upload works.

    However, often thumbnails don't get created in the preview before publishing. After I click Publish, the image appears. Annoying.

  8. Thomas Umstattd
    Member
    Posted 5 years ago #

    Is it just me or does this problem seem to have a hundred different causes?

  9. melissasue
    Member
    Posted 5 years ago #

    I'm still having this error in the actual post screen. I'm working around it by using the small quick post in the dashboard, which seems to be working for now. However, life would be easier if I could just use the bloody insert image in my post screen.

    I've tried all the fixes listed here. Hope something comes up eventually that works.

  10. berserc
    Member
    Posted 5 years ago #

    I have been plagued by this problem as well and have been able to solve it! Hopefully this will work for you:

    1) Make sure there are no other tabs or open browser windows EXCEPT the one for your editing. I think the system gets confused and doesn't know which window to drop the image into. This solved 99% of my problems (in IE and Firefox) and nothing else that was suggested worked. I originally thought it was a browser problem. This also is related to an earlier post about domain masking. I mask my domains as well and this really confuses the admin. Use the registered URL in the general settings with the /wp-admin/ to get into the admin.

    2) If you are using WPMU do not use dashes or mix capital and lowercase letters in your blog name. This might also be true for wordpress, but I use MU. I think this has something to do with the permalink structure that was stated in an earlier post, and I think they are on the right track. But I removed a dash and a capital 'I' in one of my names and images were dropping in again.

    I have had this problem since upgrading to 2.6.5 and have been able to solve it for 50+ blogs using the above methodology through 2.7.

    --
    Berserc

  11. cyclingtipsblog
    Member
    Posted 5 years ago #

    Hi,

    well, I had the same problem. The problem was that in:

    Settings > General > WordPress address i had:

    http://www.blogElectronica.com

    Then I changed the address typing:

    http://www.blogelectronica.com (without capital letters)

    and then it works fine

    I hope help you.

    Bye

    This worked for me. I changed my blog from http://www.CyclingTipsBlog.com to http://www.cyclingtipsblog.com in the WP settings. Now my media inserts are working fine. thank you blogElectronica

  12. illfxdesigns
    Member
    Posted 5 years ago #

    Yes, I was surprised to see that the problem was because of the Capitalization of the domain name in the GENERAL SETTINGS. Our company usually sets up the site on a test domain and then transfer the WP site to the actual domain, but this is the first time we had the problem. Usually though the domain name is never capitalized, but this time it was.

  13. agentsully
    Member
    Posted 5 years ago #

    The Capitalizations solution in the settings did not fix the problem for me.

    Any other solutions?

  14. agentsully
    Member
    Posted 5 years ago #

    Here's a mini workaround that I'm using in the meantime:

    Start you post in the quickpost section of the dashboard and add the image.

    Then "save draft."

    Then go to Recent Drafts, Click on your new draft and your image will be in there.

    Of course if you need to do multiple images this would be a pain, but for one it is a good workaround.

    I hope a failproof solution comes along soon!

  15. Justin Freshwater
    Member
    Posted 5 years ago #

    I had been having the same problem with the blank screen and was searching a long time for a solution.
    @brandtmarke: Thanks! your info helped the most
    It seems many people have corrected the problem by re-uploading wp-admin and wp-includes folders. While I tried this with filezilla it still did not work. I tried uploading a second time as well but chose the settings to only upload if the file wasn't there.
    With brandtmarke's help I found Total Commander and I compared the directories. The culprit was the media-uploads.js file that was uploaded but had a filesize of 0. So filezilla didn't overwrite it because it thought it was already there and for some reason wouldn't upload the file correctly when queued in a big group.
    So uploading the media upload file singly corrected everything.
    If your already logged into WordPress when you do this though, you need to log out, clear cache, and log in again to see the results.
    I hope this saves some people a lot of time; time that I wasted running in circles freaking out!

  16. teune
    Member
    Posted 5 years ago #

    The fix for me was:

    1. Deleting wp-admin and wp-includes (everything), then uploaded the latest WP 2.7.1
    2. Then re-uploaded (not overwrite) the files through FileZilla not in Default mode but in Passive mode.
    3. Clear browser cache and login.

    Good luck

  17. levous
    Member
    Posted 5 years ago #

    SOLUTION: for me, I also had my url configured with some capital letters.
    Changed the main url in settings to all lowercase and image upload now inserts into post fine!

Topic Closed

This topic has been closed to new replies.

About this Topic