WordPress.org

Ready to get started?Download WordPress

Forums

SSL Insecure Content Fixer
[resolved] Insecure Errors (9 posts)

  1. jongb
    Member
    Posted 7 months ago #

    Hi,

    Getting insecure content errors, Address is eatrightandmove.co.uk/services/

    Kind Regards,

    Jon

    http://wordpress.org/plugins/ssl-insecure-content-fixer/

  2. webaware
    Member
    Plugin Author

    Posted 7 months ago #

    G'day Jon,

    1. Revolution Slider is loading the Open Sans typeface from Google Fonts using an import from http, not https; you'll need to edit the following file, then tell the authors to fix it:

    wp-content/plugins/revslider/rs-plugin/css/captions.css

    2. Contact Form 7 is loading its AJAX spinner from http, not https; you'll need to tell the authors to fix it.

    Everything else looks good, so if you get those two things fixed you'll be OK.

    cheers,
    Ross

  3. jongb
    Member
    Posted 7 months ago #

    Hi Ross,

    Thank you for this, just waiting on Contact Form 7 for a response now.

    Thanks for the fast response.

    Jon

  4. webaware
    Member
    Plugin Author

    Posted 7 months ago #

    @jonb: I just dropped Contact Form 7 into a test site, and it doesn't give me that warning. Are you using the latest version of that plugin? Its code seems to already deal with loading the AJAX spinner over https.

    cheers,
    Ross

  5. jongb
    Member
    Posted 7 months ago #

    Hi,

    Yes I am as far as i'm aware, is there a way to drop in the latest plugin zip file without having to uninstall or lose my settings?

    I'm in talks with my Hosting to force certain directories through ssl, do you think forcing my plugins folder through ssl would work?

    Thanks again,

    Jon

  6. webaware
    Member
    Plugin Author

    Posted 7 months ago #

    G'day Jon,

    Forcing the plugins folder through SSL won't help, because the browser is going to ask for an image over http and the security settings will block that. It's the page source.

    What version of WordPress are you running?

  7. jongb
    Member
    Posted 7 months ago #

    Hi,

    That makes sense to me, running the latest version as far as I'm aware, thank you again for your help in this.

    Jon

  8. loose1
    Member
    Posted 3 months ago #

    Hi and good day to you,

    Hoping you can help please. I've detected two insecure content warnings on our sites checkout page. They relate to two images being served over http. After a lot of head scratching I am not sure how to resolve the issues. Any suggestions or guidance would be greatly appreciated.

    Have a great Easter Adrian

    https://pebblelane.co.uk/checkout/

  9. webaware
    Member
    Plugin Author

    Posted 3 months ago #

    G'day Adrian,

    1. please start a new topic, don't add to a closed topic
    2. WooCommerce does everything this plugin does, you don't need this plugin
    3. your site footer has an image with http://, change to just //

    cheers,
    Ross

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.