WordPress.org

Ready to get started?Download WordPress

Forums

Easy FancyBox
[resolved] Inline-Box displays complete site instead of hidden content (6 posts)

  1. tschiffler
    Member
    Posted 1 year ago #

    I am using your plugin since a few month
    The most time it works perfectly, since a update of wordpress it doesn´t work anymore

    if i press the image to display the box, the boxe opens but it shows the complete site instead of the content of the box.

    here is the example url:
    http://www.portrait-service.com/portrait-archiv/produktionskosten-sie-haben-die-freie-wahl/charlieengel-lab-mainz/

    Just press on the image "Unsere Produkte" and you´ll see the problem

    I don´t know if the problem is caused by the url in the link. this contains the complete url to the page instead of the single anchor. the html at the edit of the article contains only the anchor but wordpress is changing it by displaying the page

    http://wordpress.org/extend/plugins/easy-fancybox/

  2. tschiffler
    Member
    Posted 1 year ago #

    last night i worked again on the problem. the supposition i already posted in the first post has been confirmed - the problem is caused by the url in the href of the link

    i open the article in html-editing mode in the wordpress-admin
    there i enter the following href at my link:
    href="#artikelbox"

    after saving the page and navigating to the same over the user content, the link has been manipulated to the following:
    href="http://CompleteUrlToTheCurrentArticle#artikelbox"

    if i open the page in the ie webdeveloper-mode an change the url direct in the markup, the box works fine

    does anybody know how i can tell wordpress not to change my links?

  3. tschiffler
    Member
    Posted 1 year ago #

    After disabling plugin for plugin i found the reason ...

    the problem has been caused in the plugin "Google Analytics for WordPress"
    after disabling this, the popups works fine

    i just updated it and the problem has been solved

  4. RavanH
    Member
    Plugin Author

    Posted 1 year ago #

    Hi, yes Google Analytics for WordPress tends to mess with link urls for outbound link tracking purposes. I generally recommend Google Analyticator which does not do it that way...

    i just updated it and the problem has been solved

    Are you saying that after updating Analytics for WordPress the issue is solved? That would be great :)

  5. tschiffler
    Member
    Posted 1 year ago #

    thats right, i updated the "Google Analytics for WordPress" to version "4.3.2" and the problem has been solved

  6. RavanH
    Member
    Plugin Author

    Posted 1 year ago #

    But still the plugin is tracking outbound links? Or has that option been disabled after you updated?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic