WordPress.org

Ready to get started?Download WordPress

Forums

Preserved HTML Editor Markup
Initial p tag missing & plugin removes insert more tag from visual editor (2 posts)

  1. arfaRed
    Member
    Posted 8 months ago #

    Hi,

    We are using your plugin to Preserve HTML, cos our site uses HTML5 and wordpress was stripping all the HTML5 tags.
    Working ok, but we are facing the following issues

    1. Initial P tag is missing
    2. Any p tag manually added works, but when you are in Visual tab and press enter, it doesn't open a new p tag. We are also not able to apply style any content like h3, h4 cos it is not closing the p tag
    3. When we add an insert more tag through visual or text editor it gets added. But after switching to Text tab and back to Visual tab, it disappears from Visual tab. Although it is present in the Text Tab

    P.S. We have only Preserved HTML Editor Markup plugin enabled, PS Disable Auto Formatting is there but it is not activated.

    Thanks,
    Arf`a

    http://wordpress.org/plugins/preserved-html-editor-markup/

  2. onetrev
    Member
    Posted 5 months ago #

    I agree with @arfaRed regarding issue #1 and also have #3 happening to me.

    For #1, it would still be nice if a blank page in the visual editor started with a P tag so that low tech users don't mess that up and just insert content without any html tag around it.

    Regarding #3, I have the same issue, you can insert the more tag in the visual editor, but once you switch to the text tab the more tag no longer shows up in the visual editor.

    One work around for now be to make a "More" shortcode that inserts the <!--more--> tag, that might work, but the plugin can hopefully be fixed to deal with this.

Reply

You must log in to post.

About this Plugin

About this Topic