WordPress.org

Ready to get started?Download WordPress

Forums

Initial installation - can't create database (5 posts)

  1. nedsram
    Member
    Posted 2 years ago #

    Hi

    I run Windows 7 x64.

    I'm new to this. I ran the WordPress installer, reached the "Enter Application Information" page, and selected the following:

    Create new database

    Database administrator (Windows admin account name as used to log into windows - this has full administrator privileges, and I have User Account Control set to Never notify)

    DBA password - password used with the above

    Database server - localhost (the default)

    I then set the database name plap and database user brian, set the password for brian, added various unique keys as requested, and clicked on Continue.

    I then got this:

    The source is invalid
    Cannot connect to the database ". (twice)
    Access denied for user 'xxx'@'localhost' (using password:YES)

    Clearly I'm missing something here. The can't connect line seems to suggest that it's looking for an existing database but no name has been supplied - but I asked it to create a new database. Can anybody assist please? Many thanks.

  2. Elan Technosys
    Member
    Posted 2 years ago #

    Hello,

    Do you have xampp for localhost download it from http://www.apachefriends.org/

    and then try to create the database.

  3. fonglh
    Member
    Posted 2 years ago #

    You need to create the database first. WordPress doesn't create it for you. It merely asks for the information so it can connect to it.

  4. nedsram
    Member
    Posted 2 years ago #

    Thanks for the replies. This is clearly not an intuitive process.

    I uninstalled WordPress then installed XAMPP. I selected install servers for Apache, MSQL and FileZilla. Towards the end I got the following errors:

    Apache service installation failed: port 80 or 443 already in use
    MySQL service installation failed: port 3306 already in use

    I don't have Skype installed.

    In the control panel, Apache wasn't ticked, but the other two were ticked and marked as started. Clicking on Admin for MySQL gave 404 not found for http://localhost/phpmyadmin/, which I guess is because Apahe didn't start properly.

    I then looked at the event log for the Apache Server startup and it contained the following errors:

    httpd.exe: Could not reliably determine the server's fully qualified domain name, using 192.168.1.2 for ServerName .
    (OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions. : make_sock: could not bind to address 0.0.0.0:80 .
    no listening sockets available, shutting down .
    Unable to open logs .

    Any suggestions please?

    One other question. If and when I succeed in creating this database, do I need to define any tables at this stage, given that I'm not yet clear what template I will be using with WordPress?

    Many thanks.

  5. fonglh
    Member
    Posted 2 years ago #

    It looks like the installer you ran has already installed MySQL and Apache for you and they weren't uninstalled before you tried to install XAMPP.

    The 404 error is more likely because you don't have PhpMyAdmin. You can check if Apache started correctly by putting an html file in the webroot folder and going to http://localhost/

    WordPress is meant to be run on a web server, so it's assumed that you access to one, either by setting one up on your local computer or paying a webhost.

    If you're not looking to use plugins or customize your theme, try going to http://wordpress.com instead. Everything is setup for you there.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.