WordPress.org

Ready to get started?Download WordPress

Forums

WP Super Cache
Initial Install - Admin pages flash then white? (9 posts)

  1. jnnynkdcelebs
    Member
    Posted 5 months ago #

    Hello .. I believe my problem lies w/ my advanced-cache.php page.. I had created it and uploaded to the content folder.

    I also added the line to my wp-config.php file. When I then go back into my admin - anything I click on will quickly flash the contents of the page and then go white?

    The initial error thrown asked to edit permissions or create the advanced-cache.php if it did not exis, replacing CACHEHOME with /home/admin/sites/mysite.com/public_html/wp-content/plugins/wp-super-cache/

    the file that needs to be edited does not have a "CACHEHOME" rather a WPCACHEHOME... 3 instances of WPCACHEHOME as show below:

    <?php
    # WP SUPER CACHE 1.2
    function wpcache_broken_message() {
    	if ( false == strpos( $_SERVER[ 'REQUEST_URI' ], 'wp-admin' ) )
    		echo "<!-- WP Super Cache is installed but broken. The constant WPCACHEHOME must be set in the file wp-config.php and point at the WP Super Cache plugin directory. -->";
    }
    
    if ( false == defined( 'WPCACHEHOME' ) ) {
    	define( 'ADVANCEDCACHEPROBLEM', 1 );
    } elseif ( !include_once( WPCACHEHOME . 'wp-cache-phase1.php' ) ) {
    	if ( !@is_file( WPCACHEHOME . 'wp-cache-phase1.php' ) ) {
    		define( 'ADVANCEDCACHEPROBLEM', 1 );
    	}
    }
    if ( defined( 'ADVANCEDCACHEPROBLEM' ) )
    	register_shutdown_function( 'wpcache_broken_message' );
    ?>

    https://wordpress.org/plugins/wp-super-cache/

  2. Donncha O Caoimh
    Member
    Plugin Author

    Posted 5 months ago #

    Are you seeing anything in your PHP error log? What do you see when you view source any page in your admin?

  3. jnnynkdcelebs
    Member
    Posted 5 months ago #

    There are no errors in my php error log.

    In regards to my question above, can you show me how that code should be edited above ?

  4. Donncha O Caoimh
    Member
    Plugin Author

    Posted 5 months ago #

    Are you using WP Super Cache 1.4? The constant WPCACHEHOME needs to be fixed in your wp-config.php, not advanced-cache.php.

  5. jnnynkdcelebs
    Member
    Posted 5 months ago #

    @Donncha... Here are the following specs of our install.

    Version 1.4

    Step 1. Install plugin
    Step 2. Click plugin settings
    A. First error message:
    "WP_CACHE constant set to false

    The WP_CACHE constant is used by WordPress to load the code that serves cached pages. Unfortunately it is set to false. Please edit your wp-config.php and add or edit the following line above the final require_once command:

    define('WP_CACHE', true);"

    Step 3. Add define('WP_CACHE', true); to our wp-config.php file above the last require_once.

    Step 4. WP Super Cache settings..
    A. Pages flashes with info and then goes blank.
    B. View Source of blank page.
    1. `<p>Warning! WP Super Cache caching <strong>was</strong> broken but has been <strong>fixed</strong>! The script advanced-cache.php could not load wp-cache-phase1.php.<br /><br />The file /home/admin/sites/mysite.com/public_html/wp-content/advanced-cache.php has been recreated and WPCACHEHOME fixed in your wp-config.php. Reload to hide this message.</p></div><div id="message" class="updated fade"><h3>Warning! <em>Could not update /home/admin/sites/mysite.com/public_html/wp-config.php!</em> WPCACHEHOME must be set in config file.</h3><div id="message" class="updated fade"><h3>Warning! /home/admin/sites/mysite.com/public_html/wp-content is writeable!</h3>
    <p>You should change the permissions on /home/admin/sites/mysite.com/public_html/wp-content and make it more restrictive. Use your ftp client, or the following command to fix things: <code>chmod 755 /home/admin/sites/mysite.com/public_html/wp-content/</code></p>`

    Step 5. Add line of code to wp-config.php under previously added line.
    A. `define('WP_CACHE', true);
    define( 'WPCACHEHOME', dirname(__FILE__) .'/wp-content/plugins/wp-super-cache' ); `

    Step 6. WP Super Cache settings
    A. New errors up top via wp debug. Page still blank.
    Warning: include(/home/admin/sites/mysite.com/public_html/wp-content/plugins/wp-super-cachewp-cache-base.php): failed to open stream: No such file or directory in /home/admin/sites/mysite.com/public_html/wp-content/plugins/wp-super-cache/wp-cache.php on line 63 Warning: include(): Failed opening '/home/admin/sites/mysite.com/public_html/wp-content/plugins/wp-super-cachewp-cache-base.php' for inclusion (include_path='.:/usr/share/pear:/usr/share/php') in /home/admin/sites/mysite.com/public_html/wp-content/plugins/wp-super-cache/wp-cache.php on line 63 Warning: include_once(/home/admin/sites/mysite.com/public_html/wp-content/plugins/wp-super-cacheossdl-cdn.php): failed to open stream: No such file or directory in /home/admin/sites/mysite.com/public_html/wp-content/plugins/wp-super-cache/wp-cache.php on line 80 Warning: include_once(): Failed opening '/home/admin/sites/mysite.com/public_html/wp-content/plugins/wp-super-cacheossdl-cdn.php' for inclusion (include_path='.:/usr/share/pear:/usr/share/php') in /home/admin/sites/mysite.com/public_html/wp-content/plugins/wp-super-cache/wp-cache.php on line 80

    Step 7. View source of blank page
    A. Error Message in source same as step 4B

  6. erwan2014
    Member
    Posted 5 months ago #

    @Donncha O Caoimh : please could you focus a little more on this trouble I am also having (perfectly described in the first post above) and of course your plugin can't work since I don't know at all how to edit this "advanced-cache.php" file. I am not even sure I am editing the wright file (you wrote: _"Are you using WP Super Cache 1.4? The constant WPCACHEHOME needs to be fixed in your wp-config.php, not advanced-cache.php."_). Does your install process or troubleshooting informations need to be updated and if yes, when? Please be as precise as possible in your explanations.

  7. Donncha O Caoimh
    Member
    Plugin Author

    Posted 4 months ago #

    Put a slash at the end of your WPCACHEHOME definition in wp-config.php:

    define( 'WPCACHEHOME', dirname(__FILE__) .'/wp-content/plugins/wp-super-cache/' );

  8. erwan2014
    Member
    Posted 4 months ago #

    You are not answering the question. On the administration page of your plugin one can read this:


    - Could not update /home/www/###/web/wp-config.php! WPCACHEHOME must be set in config file.</p>
    <p>-- Attention! /home/www/###/web/wp-content/advanced-cache.php n'existe pas ou ne peut pas être mis à jour.</p>
    <p>1. S'il existe déjà, veuillez supprimer le fichier d'abord.
    2. Permettez à /home/www/###/web/wp-content d'être écrit en utilisant la commande chmod via votre logiciel ftp ou serveur. (chmod 777 /home/www/###/web/wp-content) et rafraîchissez cette page. Il ne s'agit que d'une mesure temporaire, et vous devrez le repasser en lecture seule ensuite. (Passez de 777 à 755 dans la commande précitée)
    3. Rafraîchissez cette page pour mettre à jour /home/www/###/web/wp-content/advanced-cache.php</p>
    <p>Si ça ne fonctionnait pas, assurez vous que le fichier /home/www/###/web/wp-content/advanced-cache.php n'existe pas :</p>
    <p> 1. Ouvrez le fichier /home/www/###/web/wp-content/plugins/wp-super-cache/advanced-cache.php$wp_cache_file dans un éditeur de texte.
    2. Remplacez le texte CACHEHOME par /home/www/###/web/home/www/###/web/wp-content/plugins/wp-super-cache/
    3. Sauvegardez le fichier et copiez-le dans /home/www/###/web/wp-content/advanced-cache.php, puis rafraîchissez cette page.</p>
    <p>Impossible de continuer... Résolvez les problèmes susmentionnés et réessayez.

    My problems:
    - the first point has no explanation at all so I don't how to fix this precisely. I know that I have to edit the wp-config.php file but don't know where and how.
    - this drives me to the second point, which has a lot of explanations on the contrary but contains obvious errors indicated by jnnynkdcelebs above (1st post).
    Actually the result is the one described in the title of this thread: Admin pages flash then white.

  9. erwan2014
    Member
    Posted 4 months ago #

    Just adopted this plugin instead (more simple):
    http://wordpress.org/plugins/w3-total-cache/
    Thx.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.