WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] @ini_set - error code appearing on index.php (4 posts)

  1. georgiegrace
    Member
    Posted 4 years ago #

    Hello!

    I set up a blog a while ago for someone else.. everything has been working fine but now he's experiencing an odd code line at the top of the main index page:

    @ini_set( 'upload_max_size' , '100M' ); @ini_set( 'post_max_size', '105M'); @ini_set( 'max_execution_time', '300' );

    URL is http://detachmentcollaboratory.org/

    As far as I can tell he hasn't made any recent changes to plugins or any other set up. Any ideas what could cause this?

    All help and suggestions very gratefully received!

    Thank you :-)

  2. esmi
    Forum Moderator
    Posted 4 years ago #

    Have you tried:

    - deactivating all plugins to see if this resolves the problem? If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the default theme to rule out any theme-specific problems?

  3. georgiegrace
    Member
    Posted 4 years ago #

    Thanks for your reply - I just got admin access to the site again.

    The error doesn't appear on the default theme. But how can I fix it? The theme was designed for this project, so I need to fix it rather than switch it.

    The theme was working fine for some time before this happened, so I'm confused as to why the error has suddenly appeared. If anyone can suggest anything I'd appreciate it.

    Thanks!

  4. sguk
    Member
    Posted 4 years ago #

    See my post, I think it has been moved to feature requests now.

    We had to add ini_set to the disable functions setting in php suhosin configuration.

    All our wordpress sites stopped working when upgraded to version 3 with server errors. WE could also put disable_functions = ini_set in a php.ini file in the top level of the wordpress folder and it does the same thing as we enabled globally.

    Enabling it globally might not be a good thing for other software but we couldn;t edit php ini in every wordpress install!

    Cubecart and cms made simple etc all seem to be working fine. We're currently researching if ini_set should stay disabled, csf firewall recommend it.

Topic Closed

This topic has been closed to new replies.

About this Topic