WordPress.org

Ready to get started?Download WordPress

Forums

WooCommerce SagePay Direct Payment Gateway
[resolved] Information received from an Invalid IP address. (Code: 4020) (6 posts)

  1. pettman
    Member
    Posted 5 months ago #

    Hello, installed your plugin and put in the vendors name, changed to test mode and get this error:

    Information received from an Invalid IP address. (Code: 4020)

    Is it a sage thing? Or plugin error?

    Thanks

    https://wordpress.org/plugins/sagepay-direct-for-woocommerce-payment-gateway/

  2. swicks
    Member
    Plugin Author

    Posted 5 months ago #

    Hi

    This is SagePay

    You need to add your IP Address through SagePay's VSP Admin. Goto Settings->Valid IPs and add your Shop's IPAddress.

    regards

    Steve

  3. pettman
    Member
    Posted 5 months ago #

    Sorry to bother you again, moved my website, added in the new valid ip address and I am not getting this error again....any help?

  4. swicks
    Member
    Plugin Author

    Posted 5 months ago #

    Hi
    Try running in simulator mode (make sure you have added your ip to SagePay) see what errors you get.

    Regards,

    Steve

  5. pettman
    Member
    Posted 5 months ago #

    Steve, all solved, hosting company gave me wrong IP address! DOH!

    All working lovely, thank you

  6. swicks
    Member
    Plugin Author

    Posted 5 months ago #

    Hi
    Thank you for letting us know what your issue was.

    Very much appreciated.

    Regards

    Steve

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.