WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Infinite Redirect Loop after moving blog (2 posts)

  1. drokkon
    Member
    Posted 2 years ago #

    Help! I need this resolved ASAP as this is a production blog - any help would be appreciated!

    My blog was set up at http://myaccount.host.com/blog, but it was actually pointed to by http://www.company.com/blog. In other words, my "WordPress Address (URL)" was set to the former, my "Site Address (URL)" to the latter.

    I need to convert this to a multisite setup with domain mapping, but unfortunately this required me to move the physical location of my blog from http://myaccount.host.com/blog to http://myaccount.host.com/.

    This was easy enough to do: I worked with my host to move the blog from the "blog" subdirectory to the root folder. Then I contacted my IT department and they pointed http://www.company.com/blog to http://myaccount.host.com instead of http://myaccount.host.com/blog.

    In WordPress, I was able to change my "WordPress Address (URL)" to http://myaccount.host.com instead of http://myaccount.host.com/blog. So far, so good - I have access to the backoffice.

    Unfortunately, the front end results in an infinite redirect loop. The ONLY way I can get it to stop is to change the "Site Address (URL)" to match the "WordPress Address (URL)", which is http://myaccount.host.com.

    However, if I do this, when a customer visits http://www.company.com/blog, they are redirected to the ugly host address, http://myaccount.host.com." This also kills our SEO.

    Ultimately, I need this to work EXACTLY as before, where a customer views our blog through http://www.company.com/blog, but the blog needs to be in the root directory of my hosting account instead of the /blog subdirectory.

    I hope that was reasonably clear - please help!

    PS - I haven't even starting setting up multisite yet - all these problems are on a simple installation.

  2. drokkon
    Member
    Posted 2 years ago #

    Please disregard. Our IT department did not have the redirect correctly set up on their end. We've resolved the issue.

Topic Closed

This topic has been closed to new replies.

About this Topic