WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Index.php working fine all other posts/pages give a db connection error?! (5 posts)

  1. Bowe
    Member
    Posted 4 years ago #

    Hi guys,

    I've just transferred my domain to a new host (so the physical adress remains the same) and I've moved my database/files to the new server. Last night the migration was complete and my site appears to be fine. I can add new posts to the admin panel and create new posts just fine. But whenever I click on one of the posts I get the dreaded error:

    Error establishing a database connection

    I'm tripplechecked my wp-config and it appears to be right.. I can visit the index page and the admin panel so I don't know what's going on here. Any help would be really appreciated!

  2. MichaelH
    Member
    Posted 4 years ago #

    URL to see the problem, please.

  3. Bowe
    Member
    Posted 4 years ago #

  4. MichaelH
    Member
    Posted 4 years ago #

    Well that's the darndest thing.

    Maybe try deleting .htaccess and updating your permalinks via Administration > Settings > Permalinks

    If that doesn't solve it, then change to the WordPress Default theme. If that doesn't solve it then deactivate all plugins.

  5. Bowe
    Member
    Posted 4 years ago #

    Thanks Michael.. I've updated my Permalinks structure and now it's working.. My permalinks are messed up, but at least It's rolling again.. I think it was a combination of the All in One SEO plugin and a messed up htaccess file that caused this.. ah well.. problem solved :)

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.