WordPress.org

Ready to get started?Download WordPress

Forums

Index.php won't work after I installed version 2.7 (4 posts)

  1. annicole72
    Member
    Posted 5 years ago #

    Hi, I just upgraded to 2.7. Now, when I go to theleomanual.com/index.php, I can't pull up my word press blog anymore. It just goes directly to my main page.

    Also, the instruction said, to delete the cache folder .. is that the one that says upgrade/cache.js? And what do I replace it with?

    What to do?

    Thanks,
    Anne

  2. meesha
    Member
    Posted 5 years ago #

    You need to be more spacific. You upgraded to 2.7 from what version? And where was that previous version installed. Or is this a new installation of 2.7?

    You can't run wordpress from your root folder if you have any .html files there. Your host has the root folder set to default to the .html file before any .php file. You can't have it both ways.

    You will have to install your wp into a sub-directory in your root like theleomanual.com/blog/ or theleomanual.com/wordpress/. You can only run wp from the root if it is the only program running from that directory.

    I'm a Leo too, so will have to check out your main pages. My mother was a Leo (what a battle for control that was when growing up). You would think I learned my lesson but no, my first love was a Leo and so was my first wife. I think I have that problem figured out now (I'm 63, so better have) as I'm not fallen for any more Leos.

  3. mikokagome04
    Member
    Posted 5 years ago #

    Actually, I currently have a index.html file in addition to the index.php file in the root directory of my blog. When I enter the URL of my blog (http://www.example.com), the WordPress blog displays. Same thing if I set it explicitly to http://www.example.com/index.php. However, http://www.example.com/index.html gets me to the index.html page, not the blog home page. Installing to a subdirectory should not be necessary. Of course, I don't know your exact server configuration, so I can't tell for sure. So far I don't see anything that should conflict with your setup. You might want to reupload your index.php file just to be sure. And also check that the blog URL you have defined in your admin settings corresponds to the right URL.

    The cache folder exists in your wp-content directory, but I think the only reason you'd see it there is if you use a plugin like WP-Cache. If you don't have this plugin, it shouldn't be there.

  4. meesha
    Member
    Posted 5 years ago #

    @mikokagome04, of course "http://www.example.com/index.html" gets you to the index.html page as that is the path you entered in your browser. Why would it go anywhere else (especially to the blog which is http://www.example.com/index.php).

    You can have different types of index pages in the same folder, but only one of them can be set as the default. It's either index.htm, index.html, or index.php. When you type in http://www.example.com it will only go to whichever index is set as the default. In your case, index.php is set to the default and as long as you only type in http://www.example.com it will always go to the blog. You may have index.html in the same folder but you will never get to http://www.example.com/index.html by just typing in http://www.example.com.

    This is a rule that controls all servers and I have never seen an exception.

    In annicole72's case, index.htm is set to be the default and when she types in theleomanual.com/index.php the blog recycles and jumps back to the root folder but since index.htm is the default, that is where it goes to instead of index.php.

    Since her blog is a sub-component of her site and not the main-component she should be running the blog out of a sub-directory.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.