WordPress.org

Ready to get started?Download WordPress

Forums

index.php won't load automatically (4 posts)

  1. learnaboutlaw
    Member
    Posted 6 years ago #

    Very weird...WP was working perfectly for months. Suddenly, without any modifications on my part, a visit to my site's front page, if formatted as : http://www.LearnAboutLawdotcom -- yields a firefox error "Firefox has detected that the server is redirecting the request for this address in a way that will never complete," or in IE, it just doesn't load.

    Now, format it as http://www.LearnAboutLawdotcom/index.php, and it loads fine.

    Or, try any other page, such as http://www.learnaboutlawdotcom/contact-us, and it loads fine.

    I know I am going to get some standard responses from the WP MASSIV (respek), but I have checked a few things already:
    -I haven't done anything to my .htaccess, it's the standard file.

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    -wp-blog-header.php is still there and is not modified.
    -there is no index.htm or index.html file that is competing with index.php.
    -modrewrite is on and working because I use permalinks and any individual page loads properly with the modrewrite engine.
    -it's not my cookies because I have tried it from several computers and through and open proxy...same result from any computer.

    i am STUMPED!

  2. learnaboutlaw
    Member
    Posted 6 years ago #

    Nobody has an idea here? This should be easy for one of the pros here

  3. Ivovic
    Member
    Posted 6 years ago #

    maybe they were put off by the WP MASSIV line.

    have you tried just deleting your htaccess file and letting wordpress re-create it?

    it may have something to do with your permalink structure, which looks to be %postname% only. consider adding some static text to that like %postname%.htm or /doc/%postname% or something.

    also check your blog addresses in your options/settings, whatever it is, you're being stuck in a redirection loop and nobody is in a better position to find out why, than you.

  4. hmfwic
    Member
    Posted 5 years ago #

    I had the same problem yesterday. It has happened before too. Several times with Network Solutions, my isp. They told me that they had to reload or re-something the index.php file. Whatever they did, it seemed to fix the problem. Apparently this time though it didn't.

    Not happy with waiting until Monday when their 'engineers' will return to work, I seemed to have fixed it myself.

    I've suspected that Wp-Super Cache contributed to the problem but couldn't pin it down. I might not have installed it right but have been using it for a couple months now. I didn't make any manual modifications, just uploaded it and activated it. Because nothing crashed, I figured it was running OK. In the future I'll just stay away from 'plugins' that need manual adjustments beyond the dashboard interface. That's just my inexperience with php.

    So after going back to the default .htaccess file, the one before wpsupercache edited it, and deactivating the wpsc plugin, the site now loads just fine.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags