WordPress.org

Ready to get started?Download WordPress

Forums

Index.php not in URL (6 posts)

  1. westpointer
    Member
    Posted 9 years ago #

    Greetings. I recently installed WordPress on a WinNT machine with IIS 4. (I know ... working on an upgrade!). The install went fine but any link that has index.php in it doesn't work correctly. For example, a category link looks like this:

    http://www.ncmb.uscourts.gov/wordpress/?cat=1

    If I click on such a link, the default index.php page is displayed. On maybe a related note, when I login, the default page does not show the dashboard topics; I only see the latest activity for my blog in the upper right hand corner.

  2. KinXen
    Member
    Posted 9 years ago #

    In options/general under Blog address (URI):, be sure to add "index.php" at the end of it.

    However, you will end up geting the same problem I have at http://wordpress.org/support/topic/32673

  3. westpointer
    Member
    Posted 9 years ago #

    Thanks for the reply. The answer seems to be ... it won't work with this configuration!

  4. Jinsan
    Member
    Posted 9 years ago #

    have searched this forum for permalinks which seems like what you want. Also I think podz mentioned using index.php in the blog address will bugger up your site

  5. westpointer
    Member
    Posted 9 years ago #

    Jinsan - thanks for the reply but it's not a permalink issue. The issues seems to be with IIS. With Apache, if it sees a link like /?cat=1 it runs that as /index.php?cat=1. But IIS trys to actually run /?cat=1 which fails.

  6. westpointer
    Member
    Posted 9 years ago #

    Also, the dashboard does not display properly (at all) which makes me think there is also some sort of xml issue.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.