WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] /index.php/ is before all pages (6 posts)

  1. bobbygarner
    Member
    Posted 2 years ago #

    I have just done a fresh install on a hosting company that I've never used in the past.

    The website is showing /index.php/ on every page except the home page. For example it looks like http://www.example.com/index.php/about.

    How can I remove "/index.php/" from these page names? Have I done something in the initial setup?

    Thanks for you help!

  2. bobbygarner
    Member
    Posted 2 years ago #

    As a followup, when I go to the Permalinks settings "/index.php/" is at the beginning of all the options except the default. If I try to make a custom setting by eliminating the "/index.php/", the change is not recognized. The "/index.php/" is still required.

  3. fonglh
    Member
    Posted 2 years ago #

    See http://codex.wordpress.org/Using_Permalinks about pathinfo permalinks.

    Perhaps your host doesn't have mod_rewrite enabled.

  4. govpatel
    Member
    Posted 2 years ago #

    Have you checked Settings>>>>>Permalinks and see if you index.php/%postname%/

  5. bobbygarner
    Member
    Posted 2 years ago #

    Thanks for the help!

    This issue was that the host did not have a .htaccess file, so no mod_rewrite.

    After uploading the file, we're in business!

  6. petesky
    Member
    Posted 2 years ago #

    Does pathinfo permalink does not work without mod_rewrite in WP 3.3.1 as joomla does ? I have a shared host without mod_rewrite and want to use pretty permalinks with /index.php/... ?!

Topic Closed

This topic has been closed to new replies.

About this Topic