WordPress.org

Ready to get started?Download WordPress

Forums

Relevanssi - A Better Search
[resolved] Indexing only 4 posts (9 posts)

  1. eschmidt99
    Member
    Posted 1 year ago #

    Hello,

    I've used Relevanssi on other sites with no problem but now it's only indexing:

    Documents in the index: 4
    Terms in the index: 63
    Highest post ID indexed: 257

    There are about 200 total posts, a few pages and the rest custom post types.

    • I've tried waiting for a while after Indexing the site for the first time.
    • I've tried hitting 'Continue Indexing' and waiting.
    • I've disabled/enabled the plugin.
    • I've uninstalled it and deleted the tables from the database and re-installed it.

    The root folder error log doesn't show anything. The only thing the error log shows in the wp-admin folder is the inability to DROP the tables when I uninstalled the plugin.

    Thank you for any help.

    Best,
    Eric

    http://wordpress.org/extend/plugins/relevanssi/

  2. eschmidt99
    Member
    Posted 1 year ago #

    Just a quick addition.

    The custom post types are set to:

    'public' => true,
    'publicly_queryable' => true,

    Thanks.

  3. Mikko Saari
    Member
    Plugin Author

    Posted 1 year ago #

    And you've checked the correct boxes on the settings page? Have you tried disabling the "respect exclude_from_search" option?

    It would require a closer look under the hood to figure out why the indexing is not working. This may be helpful: http://www.relevanssi.com/knowledge-base/how-to-debug-indexing-problems/

  4. eschmidt99
    Member
    Posted 1 year ago #

    Hello Mikko,

    Thank you for your reply.

    First, yes, all the correct boxes are checked on the Settings page, double checked.

    The indexed numbers are now at:

    Documents in the index: 63
    Terms in the index: 915
    Highest post ID indexed: 528

    This happened after I posted this question yesterday however it's still not close to the numbers that it should be indexing.

    As for the debugging, I put the code in but nothing shows. When I hit 'Build the Index' or 'Continue Indexing', it takes me to the /wp-admin/ page and no information is displayed.

    Should it be returning me to the admin home page?

    Thank you for your time,
    Eric

  5. eschmidt99
    Member
    Posted 1 year ago #

    Hello again,

    And if it matters, I'm still getting the message:

    "Relevanssi needs attention: Remember to build the index (you can do it at the settings page), otherwise searching won't work."

    At the top of my admin pages.

    Thank you,
    Eric

  6. Mikko Saari
    Member
    Plugin Author

    Posted 1 year ago #

    No, clicking "Build the index" or "Continue indexing" should not take you to the wp-admin dashboard, it should return you to the Relevanssi settings page. The message is shown, because Relevanssi hasn't finished indexing. Looks like Relevanssi is having some strange problems here, but if you could just continue indexing, it might actually work in the end.

  7. eschmidt99
    Member
    Posted 1 year ago #

    Unfortunately, it stopped indexing at 64 documents. I've tried removing it completely and reinstalling it 4-5 times now with no success.

    Do you have any other ideas?

    Thank you,
    Eric

  8. Mikko Saari
    Member
    Plugin Author

    Posted 1 year ago #

    I wonder if there's something unsavoury in the next post, for example a shortcode Relevanssi can't handle? You could try disabling shortcodes and running the indexing then to see if that helps.

  9. eschmidt99
    Member
    Posted 1 year ago #

    Hello Mikko,

    Sorry about not replying earlier.

    Disabling the shortcodes worked like a charm. Thank you very much for your time.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic