WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] index wont load (11 posts)

  1. stolle
    Member
    Posted 4 years ago #

    i moved my blog from my windows server to a linux server, i have it running from a virtual host with a total of 5 virtual hosts on the same server all my other sites work properly. i have modified the database with the new urls. my wordpress blog wont load the index i can get to the admincp and change things when i try to preview themes they dont show up just a directory listing, same with the index page i have .htaccess and it is pointing at index.php it wont load not even when you click on "index.php" the page just seems like it reloads. i have tried updating with the same result, i even tryed a new installation still does the same thing. please help i would like to get this thing going...

    thanks

  2. esmi
    Forum Moderator
    Posted 4 years ago #

    i have .htaccess and it is pointing at index.php

    What exactly is in your .htaccess file?

  3. ianatkins
    Member
    Posted 4 years ago #

    I'd delete the .htaccess file, login to your admin and update your permalink structure.

  4. stolle
    Member
    Posted 4 years ago #

    @esmi
    .htaccess:
    DirectoryIndex Index.php

    @ianatkins
    i have tryed this also, went ahead and did it again and it still does the same thing.

    below is a link to an image of what my theme preview looks like, im at a loss, i dont know what the problem is...
    link

  5. esmi
    Forum Moderator
    Posted 4 years ago #

    Try:

    DirectoryIndex index.php

  6. stolle
    Member
    Posted 4 years ago #

    thank you,

    but it still does not work, it seems i can get to all the admin areas, they function as expected, i just cant view the site. index.php and various other pages either lead me to a directory listing or a blank white page...

    actually it seems like anything that has to do with the theme doesnt work.

  7. esmi
    Forum Moderator
    Posted 4 years ago #

    I think there's a problem in your server config/setup.

  8. Whiteteeth
    Member
    Posted 4 years ago #

    good advice

  9. stolle
    Member
    Posted 4 years ago #

    i installed it in the default server in a sub directory and it works so there is something wrong with my virtual servers config and i cant figure it out. if i do though i will be sure to post it here...

    thanks

  10. stolle
    Member
    Posted 4 years ago #

    i dont get it does anyone see anything wrong with this config?

    #
    # mysite.com (/etc/apache2/sites-available/mysite.com)
    #
    <VirtualHost *>
    ServerAdmin webmaster@mysite.com
    ServerName mysite.com
    ServerAlias mysite.com

    DocumentRoot /var/www/site5/htdocs
    <Directory />
    Options FollowSymLinks
    AllowOverride All
    </Directory>
    <Directory /var/www/site5/htdocs>
    Options Indexes FollowSymLinks MultiViews
    AllowOverride All
    Order allow,deny
    allow from all
    </Directory>

    ScriptAlias /cgi-bin/ /var/www/site5/cgi-bin/
    <Directory "/var/www/site5/cgi-bin">
    AllowOverride None
    Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
    Order allow,deny
    Allow from all
    </Directory>

    ErrorLog /var/www/site5/logs/error.log

    # Possible values include: debug, info, notice, warn, error, crit,
    # alert, emerg.
    LogLevel warn

    CustomLog /var/www/site5/logs/access.log combined
    ServerSignature On

    Alias /doc/ "/var/www/site5/doc/"
    <Directory "/var/www/site5/doc/">
    Options Indexes MultiViews FollowSymLinks

  11. stolle
    Member
    Posted 4 years ago #

    it works now, i just moved wordpress to the default host and my other site to the virtual host. still dont understand why didnt work in the virtual host...

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.