WordPress.org

Ready to get started?Download WordPress

Forums

"Index of /" page comes up instead of main page (13 posts)

  1. americwp
    Member
    Posted 6 years ago #

    I upgraded to the lastest wordpress and am nearly complete now, except I have one major problem. When you go to my web blog at http://www.americanbadass.org it takes you to an index of page where you can see the cgi folder (forbidden) and the wordpress folder. Clicking on the wordpress folder gets you to the desired page.

    What I want is for people to go to http://www.americanbadass.org and not have to click on wordpress in order to see the index page.

    Under general options both the wordpress address and the blog address are set to americanbadass.org/wordpress. If I remove /wordpress from the wordpress address I get a strip down unformatted version of the general option page. If I remove /wordpress from the blog address I get the same problem with the index page coming up first, except this time clicking on the wordpress folder takes me to a "the page you requested is no longer here [error 404]", although the theme is still there.

    Any help will be greatly appreciated.

  2. whooami
    Member
    Posted 6 years ago #

    you installed wordpress into wordpress/ so given your set up why do think you can just adjust those settings (the 2 urls to something else and it just magically works-- you CANNOT.

    what you want to accomplish is done in one of TWO ways, and both are covered in the codex:

    1. http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory

    2. Just move the whole lot of stuff into your webroot > http://codex.wordpress.org/Moving_WordPress#Moving_WordPress_Within_Your_Site

    Once again, you cannot just arbitrarily change those url settings.. that why you saw no theme. There are, literally, thousdands of threads on here from ppl that have done the same and locked themselves out of the admin area -- its not meant to be done.

  3. americwp
    Member
    Posted 6 years ago #

    Thank you whoami for the quick reply. My goal is to have a separate folder to install wordpress without cluttering the root folder of my corner of the web server, which from what I read was a desirable option. I figured changing the blog or the wordpress addresses under general options wouldn't do the trick, but was just trying to give more information to provide clues of what I'm facing.

    Are you telling me I can't create a separate wordpress folder to install and update versions of wordpress without changing my url to http://www.whatever.com/wordpress ?

    Thanks again.

  4. whooami
    Member
    Posted 6 years ago #

    I believe, in fact, I know, I provided what you needed -- in the post above are 2 links, click them. Apparently, you havent, else you wouldnt be asking questions..

  5. americwp
    Member
    Posted 6 years ago #

    whoami that's where I started. It was those links that I used to come up with the idea to create a separate folder. If there is a specific part you can quote to tell me what I did wrong I'd appreciate it.

    "WordPress allows you to install the WordPress files to a subdirectory, but have your blog exist in the site root.

    That is from the first link and what lead me to believe I can do this. Again what am I missing? Something tells me I need to edit the index.php or the .htaccess file, but don't quote me on that since I'm in no position to offer myself advice anymore which is why I turn to you.

    Thanks again for the reply.

  6. whooami
    Member
    Posted 6 years ago #

    you can do it ( I have yet to say that you cannot).. you just need to follow THOSE instructions.

    You did not indicate in your first post that you had gone through all the steps listed on the first links -- ALL you indicated was that you had been changing the 2 urls -- there is more to it than that.

    READ and FOLLOW those directions.

    --

    Rant:

    I am utterly at a loss,

    Something tells me I need to edit the index.php or the .htaccess file, but don't quote me..

    If you can read on that page what you need to do, why are you telling me?? You need to do it. not post about reading about it.

  7. americwp
    Member
    Posted 6 years ago #

    Can someone a little less condensending than whoami throw me a life saver? I'm drowning here.

  8. americwp
    Member
    Posted 6 years ago #

    Here is a copy of my .htaccess file:

    # Use PHP5 as default
    AddHandler application/x-httpd-php5 .php
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /wordpress/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule ./wordpress/index.php [L]
    </IfModule>

    # END WordPress

    and here is my index.php file:

    <?php
    /* Short and sweet */
    define('WP_USE_THEMES', true);
    require('../wordpress/wp-blog-header.php');
    ?>

  9. whooami
    Member
    Posted 6 years ago #

    The post below was being written during the time that you were pasting the content of your .htaccess file above this.

    ------------

    it has nothing to do with me, it has to do with you.

    read through this thread.

    You stated what you did in the first post. I posinted to what you NEED to do.

    You obviously read it -- you quoted right off it. And yet, you keep coming back to this thread and NOT doing anything except asking the same question over and over again.

    The directions are ON THE FIRST LINK I gave you -- what is so incredibly difficult about

    1. reading them

    2. following them

    in that order?

    If you7 were to give me instructions for baking a cake, and upon reading them, I began to follow them and had trouble -- I would not return to you and ask for the instructions again -- I would say:

    "hey you know what, these instructions, the ones im following, they are telling me to preheat the oven, and I dont know how to do that. How do i do that?"

    Have you done ANYTHING like that yet? No.

    So you read and follow those instructions. When you get stuck at a step, you come back for clarification on that step.

    Follow?

    Its a 2 way street, I dont tolerate ppl that dont read well-- and Im not inclined to paste crap thats already been written by someone else.

  10. whooami
    Member
    Posted 6 years ago #

    based on the post with your .htaccess and index.php you are not following the instructions.

    You have already done 1, as your blog is installed.. start with #2.

    The process to move WordPress into its own directory is as follows:

    1. Create the new location for the core WordPress files to be stored (we will use /wordpress in our examples).
    2. Go to the Options panel.
    3. In the box for WordPress address (URL): change the address to the new location of your main WordPress core files. Example: http://example.com/wordpress
    4. In the box for Blog address (URL): change the address to the root directory's URL. Example: http://example.com
    5. Click Update Options. (Do not worry about the error message and do not try to see your blog at this point!)
    6. Move your WordPress core files to the new location (WordPress address).
    7. Copy the index.php and .htaccess files from the WordPress directory into the root directory of your site (Blog address).
    8. Open your root directory's index.php file in a text editor
    9. Change the following and save the file. Change the line that says:
    require('./wp-blog-header.php');
    to the following, using your directory name for the WordPress core files:
    require('./wordpress/wp-blog-header.php');
    10. Login to the new location. It might now be http://example.com/wordpress/wp-admin/
    11. If you have set up Permalinks, go to the Permalinks panel and update your Permalink structure. WordPress will automatically update your .htaccess file if it has the appropriate file permissions. If WordPress can't write to your .htaccess file, it will display the new rewrite rules to you, which you should manually copy into your .htaccess file (in the same directory as the main index.php file.)

  11. americwp
    Member
    Posted 6 years ago #

    Okay. I see something I missed. Instead of copying the files I was moving them. I take it that the files need to be both in the wordpress directory AND the root directory, which for my web host is /public_html.

    The good news is now the root address works, but now when I click on a page I get "page cannot be found", but when I click on a catagory I get

    "not found: The requested URL /category/special-comment/ was not found on this server."

    Sorry for not being clear on what I was after and thanks so far for the help.

  12. whooami
    Member
    Posted 6 years ago #

    you see that, because you havent updated your permalinks, its in the instructions. #11.

  13. americwp
    Member
    Posted 6 years ago #

    whoami you rock!! I'm back in business now. I hadn't gotten that far because of the other major road blocks.

    Thanks again!!!!

    "Never burn your bridges. You may have to cross them one day" (that's for me by the way).

Topic Closed

This topic has been closed to new replies.

About this Topic