WordPress.org

Ready to get started?Download WordPress

Forums

After installation - "Index of/ " - only Directory showing (7 posts)

  1. lillymouse
    Member
    Posted 5 years ago #

    Hi there,

    I've just succesfully installed WordPress 2.7 in a subdirectory: /english_second_language_jobs_events/ - I got a succesfully installed email with my admin and password.

    But when I go to my wp-admin or even the main page, I just have an Index/of like this:

    Index of /english_second_language_jobs_events

    * Parent Directory
    * index.php
    * license.txt
    * readme.html
    * wp-admin/
    * wp-app.php
    * wp-atom.php
    * wp-blog-header.php
    * wp-comments-post.php
    * wp-commentsrss2.php
    * wp-config-sample.php
    * wp-config.php
    * wp-content/
    * wp-cron.php
    * wp-feed.php
    * wp-includes/
    * wp-links-opml.php
    * wp-load.php
    * wp-login.php
    * wp-mail.php
    * wp-pass.php
    * wp-rdf.php
    * wp-register.php
    * wp-rss.php
    * wp-rss2.php
    * wp-settings.php
    * wp-trackback.php
    * xmlrpc.php

    Apache/2.2.11 (Unix) mod_ssl/2.2.11 OpenSSL/0.9.8i DAV/2 mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635 Server at http://www.iltrovainglese.com Port 80

    You can see it here:http://www.iltrovainglese.com/english_second_language_jobs_events/

    I should mention that I already have PHPBB3 installed in my root directory. Could this be the problem?

    And in the root directory, I have an .htaccess with this DirectoryIndex home.html home.htm home.php to create a new home page different from the Phpbb3 index.php... perhaps this is the problem?

    I've installed WordPress on countless websites, and never had a problem!

    Argh! :)

    any help would be better than none!

    thanks.

  2. lillymouse
    Member
    Posted 5 years ago #

    Sorry just to add, that when I click on the "index.php" it goes to a page actually designed for the PHPbb3 minus any styling, and if I scroll down I see:

    "Error 500 - Internal Server Error

    The server encountered an unexpected condition which prevented it from fulfilling the request."

    which I assume is being generated by the PHPBB3 installation not the WordPress installation?

    Oh, please let the WordPress community wake up early and read this problem. HELP! :)

  3. whooami
    Member
    Posted 5 years ago #

    I've installed WordPress on countless websites, and never had a problem!

    uh - huh.

    DirectoryIndex index.php

    ^ that goes in your .htaccess

    and if you are seeing something that belongs to phpbb then you dont have wordpress' index.php uploaded.

    you cant have 2 index.php files in the same directory -- so you need to decide ..

  4. lillymouse
    Member
    Posted 5 years ago #

    Yip, I tried that already... placing the .htaccess in my subdirectory for WordPress: /english_second_language_jobs_events

    But I have another .htaccess in the root with : DirectoryIndex home.html home.htm home.php for my Phpbb installation... I needed to allocate a new home page rather than the default phpbb index.php...

    I even tried deleting the .htaccess in the root for the phpbb installation, and adding a new .htaccess to the subdirectory with my wordpress installation adding: "DirectoryIndex index.php" still no luck...

  5. lillymouse
    Member
    Posted 5 years ago #

    sorry, you've just changed your message above... (I REALLY, REALLY have installed WordPress over 10 times :) really, without a problem)

    (This is the first time, I'm installing WordPress after a PHPBB install in the root. I've done it the other way round, first WordPress and then Phpbb in a subdirectory, without hassles)

    the two installs are in different directories

    phpbb = main root directory

    wordpress = /english_second_language_jobs_events/

  6. lillymouse
    Member
    Posted 5 years ago #

    I also tried creating an "addon domain", is that the right term? So: sub.mainsite.com

    And installing wordpress to the sub, but had exactly the same problem.

    I'm sure it's the .htaccess that I need for the phpbb installation, but is there a way round this?

  7. lillymouse
    Member
    Posted 5 years ago #

    Hey Whooami,

    Not sure you read my message right... it's long I know, but desperately in need of help.

    Mind taking a closer look at what I wrote?

Topic Closed

This topic has been closed to new replies.

About this Topic