WordPress.org

Ready to get started?Download WordPress

Forums

Index folder instead of home (9 posts)

  1. laragazzaconlavaligia
    Member
    Posted 6 months ago #

    Hello!

    I know this question has been posted several times before, but the solutions proposed in the other posts don't seem to work in my case.

    I've just bought a new hosting space and new domain, I installed WP through Softaculous. Everything seemed fine, I can login on WP and get to my dashboard, but when I try to open my site (thewatercat.com) I can only see a page with Index of/ and then cgi-bin folder. Once I click on the tag "Name" it redirects me towards my actual site, which can be found at the address thewatercat/?ND.

    I thought it was an index.php problem, but it appears to be in the right folder, public_html. Also WP seems to be installed correctly, into the public_html folder, not into a sub-folder. If I check the error_log file, this is the error I get

    [12-Jan-2014 17:53:37 Europe/Berlin] PHP Fatal error: require() [<a href='function.require'>function.require</a>]: Failed opening required '/wp-blog-header.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/mjzncjqx/public_html/index.php on line 17

    The line 17 on index.php it's like that:

    require( dirname( __FILE__ ) . '/wp-blog-header.php' );

    I tried to delete that "dirname( __FILE__ )" part, I tried to put "?>" on line 18, I tried every combination of them, and the only thing that changes is that with any edit I can't get to the website anymore, not even by clicking on "Name".

    What is the problem? Thank you very much!

  2. laragazzaconlavaligia
    Member
    Posted 6 months ago #

    I've just noticed a weird thing (maybe it's completely normal but I've never noticed before): every wp- file, aside from index.php and wp-config have been modified for the last time long before I installed WP on my domain. Is that normal?

  3. Jessy Marco
    Member
    Posted 6 months ago #

    You make wrong installation, it has to be root of the folder, where is domain pointed.

    I can do this for you if you like.

  4. Jessy Marco
    Member
    Posted 6 months ago #

    You make wrong installation, it has to be root of the folder, where is domain pointed.

    I can do this for you if you like.

  5. laragazzaconlavaligia
    Member
    Posted 6 months ago #

    But all the files were in the root directory :( Am I missing something?
    Right now I've unistalled WordPress, so I can install it again, is it ok? Can you help me?

  6. Jessy Marco
    Member
    Posted 6 months ago #

    Give me access to host I will help.

  7. laragazzaconlavaligia
    Member
    Posted 6 months ago #

    Wouldn't it be better if I actually learn how to do it?
    Anyway, I installed WP again, this time I'm completely sure that everything is installed in root directory, and nothing changed.

  8. Jessy Marco
    Member
    Posted 6 months ago #

    It would be great, but I can not help anymore with just this.

  9. esmi
    Forum Moderator
    Posted 6 months ago #

    Wouldn't it be better if I actually learn how to do it?

    Absolutely! Are you still having problems?

    @Jessy Marco: Please do not solicit access to other people's sites. We do not allow that around here.

Reply

You must log in to post.

About this Topic