WordPress.org

Ready to get started?Download WordPress

Forums

index-extra.php dashboard error (30 posts)

  1. Asukavalentine
    Member
    Posted 7 years ago #

    Hello
    I just upgraded my wordpress to 2.2 version and this error it's showing in dashboard:

    You don't have permission to access /wp-admin/index-extra.php on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    I can't see incoming links or news, everything it's with this error.
    I saw a topic opened with this but doesn't help, it says something about k2 themes that I think I'm not using.
    Any help will be really apreciated.
    Thank you!

  2. ju1ie
    Member
    Posted 7 years ago #

    I'm having the same problem. I want to know how to fix this as well.

  3. Deerhunter04
    Member
    Posted 7 years ago #

    Same thing here. I even installed a brand new copy just to test and I got the same error. Here is what i'm running:

    - WordPress 2.2
    - Apache 1.3.37
    - PHP 4.4.3
    - Mysql 4.1.21

  4. Asukavalentine
    Member
    Posted 7 years ago #

    no one?

  5. geneome
    Member
    Posted 7 years ago #

    Whew! It's not just me then. I'm having the same issue... tried everything I know. Reinstalled it, changed the permissions of the file, reset my options... and still the dashboard is messed up.

  6. loudestnoise
    Member
    Posted 7 years ago #

    I never have problems when upgrading to new versions of WP, but I am experiencing this issue too. It is quite annoying, and I too have tried re-installing a couple of times.

  7. rosscbrown
    Member
    Posted 7 years ago #

    Same issue. Proving to be a right pain, in that my custom error pages are being called and the sheet-style etc are making the dashboard unusable.

    Until someone posts a fix, i have just removed a chunk of script towards the top of the index.php file (in wp-admin) that seems to call the files.

    It more or less deletes the three areas so its not a long them fix - just makes it look nice if you *need* to use it.

    Ross.

  8. loudestnoise
    Member
    Posted 7 years ago #

    Ya, so deleting

    <script type="text/javascript">
    Event.observe( window, 'load', dashboard_init, false );
    function dashboard_init() {
    	var update1 = new Ajax.Updater( 'incominglinks', 'index-extra.php?jax=incominglinks' );
    	var update2 = new Ajax.Updater( 'devnews', 'index-extra.php?jax=devnews' );
    	var update3 = new Ajax.Updater( 'planetnews', 'index-extra.php?jax=planetnews'	);
    }
    </script>

    makes it stop. I guess this is part of the new AJAX added in 2.2 but it causes the index.php to go wacky

  9. whooami
    Member
    Posted 7 years ago #

    did you delete the exiting files and then upload the new files inside wp-includes/js ???

    I cannot reproduce that EXACT error because I suppress error messages, however I can break my dashboard display by essentially deleting that particular directory.

    95% of upgrade problems seem to be with people not following directions.

  10. rosscbrown
    Member
    Posted 7 years ago #

    yes, i did. furthermore, dashboard breaks on clean install (not upgrade).

  11. whooami
    Member
    Posted 7 years ago #

    welp, it doesnt break for me, either with an upgrade or a clean install. dunno.

  12. Vengador
    Member
    Posted 7 years ago #

    I'm having the same problem :( If I show index-extra.php it works correctly but in Dashboard don't work :(

  13. Asukavalentine
    Member
    Posted 7 years ago #

  14. Deerhunter04
    Member
    Posted 7 years ago #

    Thanks for the link Asukavalentine. That helped me out a ton. I went ahead and edited my .htaccess in my root directory and added this:

    <Files index-extra.php>
    SecFilterInheritance Off
    </Files>

    That fixed my problem. I didn't want to turn off mod_security for the entire wp-admin folder, so this way just turns it off for index-extra.php file.

  15. Samuel Wood (Otto)
    Tech Ninja
    Posted 7 years ago #

    None of this stuff is new to 2.2. It was all there in 2.1.3 as well. I think there's some other kind of major issue you're having here. Probably a bad html_type or something.

  16. Deerhunter04
    Member
    Posted 7 years ago #

    Well, something must have been changed. I was running 2.1.3 without any problems, did the normal upgrade like i always do, and began having problems with 2.2.

  17. Asukavalentine
    Member
    Posted 7 years ago #

    Help in the topic I found this morning didn't work, I asked support for change it in my server and now I can't post in the blog:

    Forbidden
    You don't have permission to access /wp-admin/post.php on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    --------------------------------------------------------------------------------

    Apache/1.3.37 Server at http://www.bellsoffreedom.net Port 80

    I will ask them for put it back to normal and try Deerhunter's option.

  18. loudestnoise
    Member
    Posted 7 years ago #

    I know how to edit the .htaccess file, but when I add

    <Files index-extra.php>
    SecFilterInheritance Off
    </Files>

    I get a 500 Internal Server Error

    Where do I add this and does it matter with the order?

  19. Deerhunter04
    Member
    Posted 7 years ago #

    I have my .htaccess in the root folder of my webserver. For me, that is the public_html folder. I do not have a .htaccess file in my wordpress directories.

    That is the only thing i have in my .htaccess file, so i'm not sure if there is a specific order or not. I really doubt the order matters at all.

  20. geneome
    Member
    Posted 7 years ago #

    The .htaccess hack was the key for me.

    @loudestnoise
    For my .htaccess in my wordpress folder (www.mysite.com/blog) I have this in it:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /blog/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /blog/index.php [L]
    </IfModule>

    <Files index-extra.php>
    SecFilterInheritance Off
    </Files>

    # END WordPress

  21. moshu
    Member
    Posted 7 years ago #

    Whatever htaccess thing you want to be applied to your WP install - the file has to be in the WP's root, not the site's root.

  22. Deerhunter04
    Member
    Posted 7 years ago #

    I'm not sure what to say Moshu, but my .htaccess is in my site's root and it solved my problem. I'll play around with it. Maybe i did another change that is working and i'm thinking it's the .htaccess.

    Glad everything is working for you guys.

  23. qivlie
    Member
    Posted 7 years ago #

    thanx for all, it fixed my troble.
    remember put the code in first line in .htaccess file
    e.g:

    # -FrontPage-

    <Files index-extra.php>
    SecFilterInheritance Off
    </Files>

    IndexIgnore .htaccess */.??* *~ *# */HEADER* */README* */_vti*

    <Limit GET POST>
    order deny,allow
    deny from all
    allow from all
    </Limit>
    <Limit PUT DELETE>
    order deny,allow
    deny from all
    </Limit>

    ;-)

  24. aeongate
    Member
    Posted 7 years ago #

    I have tried most versions of the .htaccess-fix but keep casuing an internat server error which ever way I do it. Could this mean there is simply something with the the settings on the server that don't allow a modification like this?

    Most things do work, of course, but it´s a little frustrating :)

  25. juiceee
    Member
    Posted 7 years ago #

    We have the same frustrations. Mine doesn't work either.

  26. aeongate
    Member
    Posted 7 years ago #

    Ok, new additional problem. All of the sudden the pages can not be accessed at all. 404 Error. Wonder what is going on?

  27. aeongate
    Member
    Posted 7 years ago #

    The last problem resolved. After having replaced the .htaccess-file with the original one the pages can be accessed again. Sorry for the confusion :) Thought I had already replaced it. The problem with the dashboard remain, though ...

  28. Brayne
    Member
    Posted 7 years ago #

    I know how to edit the .htaccess file, but when I add

    <Files index-extra.php>
    SecFilterInheritance Off
    </Files>

    I get a 500 Internal Server Error

    Where do I add this and does it matter with the order?

    when ever I monkey with the htaccess, and I get a 500 error, I make sure to save the code with the proper format.
    "raw text" or "unix code".
    Your text editor might be messing you up there.

    This problem has happened on a clean-new install for me as well. The htaccess addition fixed it.

  29. wpiisnewbie
    Member
    Posted 7 years ago #

    OK. I'm running wp 2.2 on a windows 2003 server; IIS 6. Site: grace.cardwellcreative.com. I'm having a similar, but slightly different issue with the Dashboard. Mine seems to be related to the Event Calendar plug in (version 3.1). I only get the dashboard error when the EC3 plug in is activated.

    The error I see in the dashboard reads:
    "CGI Error
    The specified CGI application misbehaved by not returning a complete set of HTTP headers."

    We have narrowed it down to a problem with the index-extra.php file. As I said, though, if I disable the EC3 plug in, all is well. Hope this helps someone (and hopefully me).

  30. contraheroe
    Member
    Posted 6 years ago #

    i had the same problem with 2.2, i created a text file and put this

    <IfModule mod_security.c>
    SecFilterInheritance Off
    </IfModule>

    save this txt file, then rename the file .htaccess and upload it into your wp-admin foledr, refresh your dashboard and the problem will be fixed, i also had a problem with categories, it didnt allow me to ad categories and posted the same error of forebidden thing, then it was also fixed, thanks guys for the tip!!

    nacho

Topic Closed

This topic has been closed to new replies.

About this Topic