WordPress.org

Ready to get started?Download WordPress

Forums

Indented bullets not created properly with tinyMCE Indent button (2 posts)

  1. dsttexas
    Member
    Posted 2 years ago #

    Using the tinyMCE indent button to create sublevels in unordered bullet lists does not create correct html.

    This is the problem:

    The code sequence below is the correct html for indented bullet lists, and will pass validator and will save correctly with "autofix" ON.

    (Inserted blanks in tags so they will show through)

    <ul >
    <li > first line</li >
    <li > second line (note no </li > tag here)
    <ul >
    <li > first indent line</li >
    <li > second indent line</li >
    </ul >
    </li >(note this tag needs to be here not above)
    <li > third normal line</li >
    </ul >

    However, the visual editor will NOT create this correctly, as it places the noted </li > above at the end of "second line" above, and not at the end of the sub-setted items. Also, the auto fix cleanup process is not properly recognizing this nested list tag issue to fix it correctly, but just messes it up more.

    Turning autofix OFF in Settings / Writing will allow the incorrect MCE created code to still display properly when saved. Running validator will list a bunch of problems, but not recognize the real issue.

    (MCE indent really makes a mess of indented ordered lists, by using numbers at every level - yuk!)

    In searching the forums, I found a forum and bug report, but it was closed as not reproducible years ago.

    http://wordpress.org/support/topic/ordered-list-nesting-in-the-wysiwyg-editor

    http://core.trac.wordpress.org/ticket/2145#

  2. WPyogi
    Volunteer Moderator
    Posted 2 years ago #

    TinyMCE has various problems -- you might want to try CKeditor plug-in instead -- people have reported that it works better.

Topic Closed

This topic has been closed to new replies.

About this Topic