WordPress.org

Ready to get started?Download WordPress

Forums

Increasing post title text width (15 posts)

  1. mrpuha
    Member
    Posted 1 year ago #

    I am a beginner
    I am using Gridly wordpress theme.
    I can't figure out how to make the text in the title of the posts the same width as the featured image. (Or left aligned with the featured image)

    the site I am building: http://blackboxstudios.org/studios/

    any advice greatly appreciated

    thanks

  2. Jay Hoffmann
    Member
    Posted 1 year ago #

    Took a look at your site. Do you have familiarity with how to update a CSS stylesheet? Right now your content box looks like this:

    #post-area .post .gridly-copy {
    width:250px;
    margin-left:auto;
    margin-right:auto;
    padding-top:10px;
    paddingbottom:20px;
    overflow:hidden;
    clear:both;
    }

    Notice that right now "margin-left" and "margin-right" are both set to auto. All you need to do is delete both of these from the class and your content will be aligned to the left.

    For you, you can use your FTP to navigate to: http://blackboxstudios.org/studios/wp-content/themes/gridly/css/light.css

    Then find "#post-area .post .gridly-copy" and delete "margin-left" and "margin-right."

    Also, if you want to make the whole box a little wider, since everything will be pushed to the left now, you can increase the "width" attribute to ~300px.

    Hope this helps.

  3. mrpuha
    Member
    Posted 1 year ago #

    Hi, thanks a lot for your very quick and very clear answer.
    I followed your instructions and deleted "margin-left" and "margin-right." from #post-area .post .gridly-copy" but nothing seems to have changed.
    any idea what you think the problem could be ?

  4. mrpuha
    Member
    Posted 1 year ago #

    to be clear I mean on the "home" page

  5. Jay Hoffmann
    Member
    Posted 1 year ago #

    And you saved and updated the CSS file? I'm still seeing margin-left and margin-right set to auto.

    Another way to fix it is to add a value to margin-left, something small. Try margin-left: 5px; This will force a value and move all of the content to the left side. Make sure to update your CSS file and clear your cache to see the changes. I would do this, it's a good way to test to make sure you are doing it right.

  6. mrpuha
    Member
    Posted 1 year ago #

    thanks again !
    yes I saved it and emptied cache and this time I tried margin-left: 5px
    but still no results
    this is my address chain /studios/wordpress/wp-content/themes/gridly/css

  7. Jay Hoffmann
    Member
    Posted 1 year ago #

    I'm not seeing any changes to your CSS, are you sure you are editing the "light.css" file?

    Also, I noticed there are two places that you can try changing. Both "#post-area .post .gridly-copy" and ".gridly-copy" can be changed to margin-left:5px;

    Once you've tried this, use a tool like Firebug for Firefox, or on Chrome, right click on the headline and select "Inspect Element." This should give you a view of your CSS styles. It's a good way to see if they've been updated. Somewhere along the chain the file is not being updated so make sure you check.

  8. mrpuha
    Member
    Posted 1 year ago #

    Thanks again
    I haven't downloaded Firebug yet (because on somebody elses computer) but I have downloaded the "light.css" file onto another computer and the file is indeed altered with deleted "margin-left" and "margin-right." from #post-area .post .gridly-copy" as well as ".gridly-copy"

    it's possible that I am missing something very basic as I really have no experience at all with this

  9. Jay Hoffmann
    Member
    Posted 1 year ago #

    Interesting. When I visit http://blackboxstudios.org/studios/wp-content/themes/gridly/css/light.css
    I'm still seeing the auto set on the margins.

    Are you using any cache plugins like super cahce or total cache? If so, disable these plugins temporarily. Other then that, you may just have to wait until the server updates the files, though that should be done by now. Click the link above to see the CSS file I am talking about.

  10. mrpuha
    Member
    Posted 1 year ago #

    thanks again
    yes I see it too on your link
    your path is http://blackboxstudios.org/studios/wp-content/themes/gridly/css/light.css
    and mine is
    http://blackboxstudios.org/studios/wordpress/wp-content/themes/gridly/css/light.css
    could it be that they are slightly different ?

  11. Jay Hoffmann
    Member
    Posted 1 year ago #

    Yup, they are very different. The one that you posted has /wordpress after blackboxstudios.org/studios. What you need to do is navigate to the /wp-content in your root directory, not the one in your /wordpress directory.

  12. mrpuha
    Member
    Posted 1 year ago #

    thanks again
    ok /wp-content isn't in my root directory only inside the wordpress folder - should I move it into the root from the wordpress folder ?

  13. Jay Hoffmann
    Member
    Posted 1 year ago #

    I definitely wouldn't move the directory. The thing is, your WordPress blog URL is http://blackboxstudios.org/studios. That means that WordPress installed in your /studios folder. Am I correct in this assumption? If you visit http://blackboxstudios.org/studios/wordpress/ then you get a 404, meaning nothing is there. It's weird that you have a /wordpress directory inside the root, since it seems like there is nothing there.

    Are you sure you're following your FTP to /studios and then searching in there for /wp-content? Are there any redirects in place?

  14. mrpuha
    Member
    Posted 1 year ago #

    got it ! there were 2 directories called studios so the path was /studios/studios/wp-content/themes/gridly/css

    god bless you sir - thanks for your patience and expertise !
    magic

  15. Jay Hoffmann
    Member
    Posted 1 year ago #

    Ah I see, those paths can be tricky :D

    Glad I could help!

Topic Closed

This topic has been closed to new replies.

About this Topic