WordPress.org

Ready to get started?Download WordPress

Forums

Increase Max Upload size with WP 2.1? (13 posts)

  1. revolute
    Member
    Posted 7 years ago #

    Several topics address the issue of upping the max upload capabilities for in-post control panel uploads on WP, however, I've had no success with any of the suggestions / plug-ins.

    I've tried adding:

    php_value upload_max_filesize 6M

    to .htaccess, and am told to put it instead in php.ini

    even after adding to php.ini, I still get the following message:

    The uploaded file exceeds the upload_max_filesize directive in php.ini.

    is it for some reason not recognizing 6M as 6MB? is there something I'm missing? I don't believe I should have any issues with uploading larger than 2MB on my server (I use BlueHost).

    Any help will be much appreciated.

  2. Samuel B
    moderator
    Posted 7 years ago #

    To increase max upload size of your PHP installation in php.ini (PHP configuration file) set this options:

    * upload_max_filesize 6M
    * post_max_size 6M

    to a desired value (6M for instance :>)).

    Using MySQL storage engine (check that on Administration -> Configuration -> General page) you will most probably need to increase max packet size. You can do that by putting:

    set-variable = max_allowed_packet=6M

    in mysql section of your MySQL configuration file (usually name my.cnf).

    The mysql part may or may not be needed depending on host config.

  3. revolute
    Member
    Posted 7 years ago #

    I still can't seem to figure this out. Looking at mySQL, I've got this:

    max allowed packet: 33,553,408

    which looks like it should be more than sufficient.

    is it possible that my php.ini is not written correctly?

  4. syamala
    Member
    Posted 7 years ago #

    I encounter the same issue. I set a huge value (25MB) in php.ini and my max allowed packet: 33,553,408. But still it doesnt allow me to upload a 14 MB file?

    Any resolution on this issue?

  5. Tom Lany
    Member
    Posted 7 years ago #

    You could just FTP your files and then link them manually. I know this would be a bit more work, though.

  6. syamala
    Member
    Posted 7 years ago #

    Essentially i want others to post files on my website, but i dont want to share the ftp password of my whole website. So in that case, only option would be to upload files from within the post correct? Are there any plugins that could help me do this.

  7. Sproke
    Member
    Posted 7 years ago #

    I don't have a direct answer, but have you tried a file-sharing site like 4shared.com ? I really like 4shared because you can choose what folders and folders you want to share, and also you can allow people to upload to to a particular folder. I know this isn't ideal, but might be an idea.

  8. rbrainard
    Member
    Posted 6 years ago #

    For what it's worth, I had to put the changed php.ini file into the folder that the uploads were going to.

    Mine were located in public_html/wp-content/uploads

  9. ericr23
    Member
    Posted 6 years ago #

    I also had to put a php.ini file with the upload_max_filesize setting in the wp-admin directory.

    Since I'm on dial-up, I haven't tested whether that's the only necessary location or if the one in the uploads directory is also needed.

    My blog is in a subdirectory of my site, so WP's behavior in this regard may be different.

    (I also included a post_max_size setting, but again don't know if that was necessary -- I can't tell if WP is using the POST method.)

  10. elginroots
    Member
    Posted 6 years ago #

    i use hostican and was able to find out how to fix the problem there. i changed the php.ini upload_max_filesize 10M
    then COPIED php.ini TO the wp-includes and wp-admin folders. then i refreshed the import page, started over, and it worked.

  11. theZman
    Member
    Posted 6 years ago #

    make a file called " .htaccess "

    insert these values useing, say, text edit...

    php_value post_max_size 110M
    php_value upload_max_filesize 100M
    php_value memory_limit 32M

    php.ini does not work like you would think...i have had better luck with the .htaccess method.

    i think the php.ini file only works that way when its in the cgi bin, at least thats what i have been told. try the .htaccess way for a quick fix. worked great for me...

  12. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    The .htaccess trick only works if you are running PHP as "mod_php" and not if you are running it as a CGI.

    The PHP.INI file is the only other way to do it, but it will work both ways. But not all hosting services will allow you to change this setting in the first place.

    In short, if you can't figure it out, ask your hosting service how to do it. They'll either tell you how or tell you no. And that will be the final word on it.

  13. Shyzer
    Member
    Posted 6 years ago #

    I just wanted to chime in and say thanks to Zman. The htaccess code did just the trick and allowed me to upload an 8MB file. Thanks!

Topic Closed

This topic has been closed to new replies.

About this Topic