WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
Incorrect Cache Engine (11 posts)

  1. Martin Tod
    Member
    Posted 1 year ago #

    Anyone else getting this error message every time they post or comment?

    Any ideas on how to fix it?

    http://wordpress.org/extend/plugins/w3-total-cache/

  2. redkite
    Member
    Posted 1 year ago #

    I'm getting it too, no idea how to fix it at this point.

  3. Grumbledook
    Member
    Posted 1 year ago #

    I've also been getting it for the last day since upgrading the plugin...

  4. norecipes
    Member
    Posted 1 year ago #

    I'm having the same problem. It happens when I try to edit and save an existing post. I tested with comments, but I use Disqus so it doesn't seem to affect the comments. Here's the full error:

    Warning: Incorrect cache engine in HOME_DIR/wp-content/plugins/w3-total-cache/lib/W3/Cache.php on line 76

    Warning: Cannot modify header information - headers already sent by (output started at HOME_DIR/wp-content/plugins/w3-total-cache/lib/W3/Cache.php:76) in HOME_DIR/wp-includes/pluggable.php on line 876

  5. Floss68
    Member
    Posted 1 year ago #

    Also having the same issue. Have been on plugin page but can't see any info on it.

    Warning: Incorrect cache engine in /home/proprodu/public_html/wp-content/plugins/w3-total-cache/lib/W3/Cache.php on line 76.

    Warning: Cannot modify header information - headers already sent by (output started at /home/proprodu/public_html/wp-content/plugins/better-wp-security/inc/secure.php:1089) in /home/proprodu/public_html/wp-includes/pluggable.php on line 876

    Hope a fix comes through fast as it's causing a few issues for me including contact page text formatting. Also can't upload new header design.

  6. Frederick Townes
    Member
    Plugin Author

    Posted 1 year ago #

    Have you tried resaving the settings from the General Settings page? Also make sure that there are engines listed and selected for Page Cache, Database cache and Object Cache if you have them enabled. The error means that a cache engine that does not exist is being used. Possible cause is a corrupt configuration/settings file so the plugin can't figure out which engine is being used.

  7. mackaaij
    Member
    Posted 1 year ago #

    @Frederick: Thanks for the terrific support again. I had this issue. Saving General Settings returned an error regarding rights. After chmod I was able to save settings and the issue is gone now.

  8. redwoodresident
    Member
    Posted 1 year ago #

    Thanks, that did the trick!!!!

  9. cdragon22
    Member
    Posted 1 year ago #

    I tried all of the above and continue to get those errors.

  10. psalmofpaul
    Member
    Posted 1 year ago #

    Performance > General Settings - Click 'Save all settings' button

    Then click 'Enable' button

    Then click 'Deploy' button

    Blessings..

  11. erineco
    Member
    Posted 1 year ago #

    When I try to log into my wordpress admin, I receive this error message:

    Warning: Incorrect cache engine in /home/erin/public_html/websiteaddress.com/wp-content/plugins/w3-total-cache/lib/W3/Cache.php on line 76

    Warning: Cannot modify header information - headers already sent by (output started at /home/erin/public_html/websiteaddress.com/wp-content/plugins/w3-total-cache/lib/W3/Cache.php:76) in/home/erin/public_html/websiteaddress.com/wp-includes/pluggable.php on line 876

    I logged into cpanel but I am not sure how to fix this one. Do I delete the w3-total-cache.php from my plug ins folder?

    Any advice would be greatly appreciated.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic