WordPress.org

Ready to get started?Download WordPress

Forums

Incompatible archive: PCLZIP_ERR_BAD_FORMAT (-10) (36 posts)

  1. tyankee
    Member
    Posted 4 years ago #

    I just tried upgrading from 2.7 to 2.8 via the upgrade button in teh admin panel and i got this error:

    Downloading update from http://wordpress.org/wordpress-2.8.zip

    Unpacking the core update

    Incompatible archive: PCLZIP_ERR_BAD_FORMAT (-10) : Unable to find End of Central Dir Record signature

    Installation Failed

    i've updated 6 of my other blogs with no problems, including 1 other with the same theme and plug-ins..

    any ideas??

  2. gualtiero
    Member
    Posted 4 years ago #

    Here the same error!

  3. yorch
    Member
    Posted 4 years ago #

    Same error after upgrading to 2.8. It's a bug of this version. I found the solution here, this is how:
    Replace wp-includes/http.php with this.

  4. tyankee
    Member
    Posted 4 years ago #

    didn't work - sorry..

  5. jazyfko
    Member
    Posted 4 years ago #

    something is wrong with 2.8... i think its one of the bugs... sorry, no solution.

  6. MichaelH
    Member
    Posted 4 years ago #

  7. tyankee
    Member
    Posted 4 years ago #

    thank you... is there a way to be notified automatically if someone responds to this thread - like other forums?? id don't see it anywhere and really don't have the time to login every day to check..

    thanks..

  8. MichaelH
    Member
    Posted 4 years ago #

    You could put your email in the "Add to Cc:" field on that ticket.

  9. gualtiero
    Member
    Posted 4 years ago #

    any news?

  10. klajdi2
    Member
    Posted 4 years ago #

    I have the same problem :(

  11. skysnow
    Member
    Posted 4 years ago #

    The http replacement doesn't work.

  12. gualtiero
    Member
    Posted 4 years ago #

    It's quite strange here, other sites on the same server are updating properly. Except the most important site.... :(

  13. Samuel Wood (Otto)
    Tech Ninja
    Posted 4 years ago #

    Upgrade manually. It's not difficult. The automatic upgrade is a convenience thing only, it's not always going to work everywhere.

    Upgrading WordPress

  14. Alexandre
    Member
    Posted 4 years ago #

    I was having the same problem. Turns out I had maxed out the storage space I had acquired on the server my site is hosted on. Noob mistake, I know...

    It's working now.

  15. gariben
    Member
    Posted 4 years ago #

    @Otto

    yeah.. what about plugins.. it could get pretty bad quickly if you have multiple blogs with plugins.

    having to FTP to upload plugins especially with the virus scare (Gumblar)

  16. mathrafal
    Member
    Posted 4 years ago #

    You should also check your webspace. I had this with a customer's upgrade, and it was right on the edge . . . I gave him a few more MB server space and all was fine.

    J

  17. texeyes
    Member
    Posted 4 years ago #

    In my case this error was not a result of a bug at all. It was because as a few above has said, I had maxed out the storage space on my host. I originally tried to upgrade a wordpress version on http://DailyNewsGuide.com and then I tried to simply upgrade various plug-ins on http://BankFly.com and always received the error above. Going into WHM on hostgator and increasing my packages quote resolved the issue immediately. I wanted to thank everyone on this post for help!

  18. audioel
    Member
    Posted 4 years ago #

    Hello, I had the same problem since 2.8.2, and I solved it by commenting out mbstring.func_overload in my php.ini file:

    ; mbstring.func_overload = 7

    Upgrades and uploads worked perfectly after that.

  19. thatmtnman
    Member
    Posted 4 years ago #

    I can confirm that by increasing the storage limit that error goes away...

    cheers!

  20. olja1
    Member
    Posted 4 years ago #

    audioel, where to find php.ini ?

  21. ammarali0300
    Member
    Posted 4 years ago #

    audioel, I annot find php.ini file. Please help me and tell the location of the file. Thanks

  22. Linda Lee
    Member
    Posted 4 years ago #

    ajanini- that was my problem too! Thank you for posting that.
    Easy fix and so easy to miss.
    :)

  23. Sproke
    Member
    Posted 4 years ago #

    I am having the same problem, both with upgrading wordpress and plugins. I have enough space on my server to do the upgrading, but I do not have a 'php.ini' file. Would someone please clarify this?

    Thanks

  24. kmessinger
    Volunteer Moderator
    Posted 4 years ago #

  25. cableghost
    Member
    Posted 4 years ago #

    I simply and successfully manually installed it (ftp folder to plug-ins folder), then avtivated it (using WP ver 2.9.2).

  26. GESWho
    Member
    Posted 4 years ago #

    I was able to manually update to WP 2.9.2 on a machine I have local rights to, but then I turned on FTP temporarily and confirmed I could write to the wordpress folders using a stand alone FTP client. The volume has over 40GB free, so it's not a space issue. I get exactly this under 2.9.2 on said machine:
    Downloading install package from http://downloads.wordpress.org/plugin/(everything I've tried that says it should work w/2.9.2, so far)....
    Unpacking the package.
    Installing the plugin.
    Incompatible Archive
    Plugin Install Failed.
    Actions: Return to Plugin Installer

    my php.ini has already got the line quoted above commented out, assuming that commented out means it has a ";" at the beginning of the line, like all of the other commented out lines... ;)

    Thoughts all?

  27. summityourlife
    Member
    Posted 4 years ago #

    I downloaded a zipfile for a new theme I want to add to my WordPress blog. When I go to upload it into WP I get the following message:

    Incompatible archive: PCLZIP_ERR_BAD_FORMAT (-10) : Unable to find End of Central Dir Record signature

    I am a novice at this stuff so this error message has really thrown me. Thx

  28. thefighter14
    Member
    Posted 4 years ago #

    SOLUTION - SOLUCIÓN

    English

    I have the solution. Download and decompress the zip file, then recompress [only all files and folders within ZIP file] and upload it to /wp-content/plugins/

    ESPAÑOL

    Descarga, descomprime, comprime, sube, i eso es todo, solo asegúrate de comprimir no una carpeta sino los archivos [y carpetas] que están dentro del archivo ZIP

  29. thefighter14
    Member
    Posted 4 years ago #

    PD:

    At least that worked for me.
    Oh, I forgot, do not put special compression features, otherwise the same thing will happen

    -------

    Al menos eso funcionó para mi.
    Ah, me olvidaba no pongan características especiales de compresión, si no ocurrirá lo mismo.

  30. ken-search
    Member
    Posted 4 years ago #

    Hi,

    For persons getting this error you need to increase the space available to your client on your web server. I had this problem because I had given my client 50 mb and they uploaded a few pictures to their gallery. After I increased the space all issues were resolved

Topic Closed

This topic has been closed to new replies.

About this Topic