WordPress.org

Ready to get started?Download WordPress

Forums

Incoming Links 404 error (4 posts)

  1. cicakchanson
    Member
    Posted 11 months ago #

    Hi everyone... I hope you can help cause this is driving me nuts.

    I set up a site and have since mapped it to a different domain. I added some pages just recently and set up some links to them on a hard coded HTML/CSS menu that appears on each page. The problem is that every time I click the tab on my new menu to access the pages I've just created I get redirected to a 404 error page. The kicker is that going into the backend of wordpress and clicking the "view page" button (off the page I just created) takes me right to the front end of the page with no problems and the URL of the new page is identical to the URL I just tried to access with my html/css menu. So in short I can get to the new page by going into the back end but not by clicking an external link on the front end. I noticed also in Safari that some odd "stuff" gets added to my URL and it attempts to go to my 404 page. However, if I stop the load of the page and delete the "stuff," then click return, the page loads just fine. AHHHHH! :-(

    I have unmapped the custom URL I was using and tried deleting and recreating the pages under different names but no joy. All my other pages work great and they are had taps in the same HTML/CSS menu that I mentioned earlier. Any ideas?

  2. Sunder Deep Dasna
    Member
    Posted 11 months ago #

    Please write the url of your site.

  3. cicakchanson
    Member
    Posted 11 months ago #

    Sure,

    http://www.thewanderingguru.com/m2world/grade-8/

    Click on the "8.2 blog" tab and you'll get the 404 error. Now try copying and pasting the URL that resulted in the error into a new browser window. I think you'll find that

    http://www.thewanderingguru.com/m2world/grade-8/blog-8-2/

    changes to:

    http://www.thewanderingguru.com/m2world/grade-8/blog-8-2/%E2%80%8E

    The "stuff" I was referring to before is "%E2%80%8E." Not sure why this is getting added.

    Thanks for your help.

  4. cicakchanson
    Member
    Posted 11 months ago #

    Ok. The bizarreness is over.. in the interest of helping others this was the best article that I could find on the issue I was having. Interestingly enough the solution was to copy a working hard coded link over again and manually retype the slug. Weird!

    I also learned hard coding links is a NO No... I will repent...

    http://wordpress.stackexchange.com/questions/84094/why-doesnt-one-of-my-links-in-the-footer-work-properly

Reply

You must log in to post.

About this Topic