WordPress.org

Ready to get started?Download WordPress

Forums

Inbuilt gallery order won't save (4 posts)

  1. jaholdensr
    Member
    Posted 1 year ago #

    Hi all,

    I have an issue with the inbuilt gallery. Dragging and dropping the images in the list and then clicking "Save all changes" results in the gallery list reloading with the images in the original order.

    I've tried in Firefox and Chrome, and have also tried with all plugins disabled.

    There are around 135 images in the gallery.

    The template is "Voila" from TemplateMonster, with a little minor cosmetic adjustment, although this shouldn't affect wp-admin.

    Has anyone seen this issue before? I searched but couldn't find anything.

    Thanks in advance,

    James

  2. esmi
    Forum Moderator
    Posted 1 year ago #

    Have you tried:

    - deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the Twenty Eleven theme to rule out any theme-specific problems (yes - themes can affect the wp-admin area).

    - resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

  3. jaholdensr
    Member
    Posted 1 year ago #

    Thanks for the quick reply, esmi.

    I did deactivate all the plugins and it didn't help.

    I just tried the other two suggestions and they didn't help either.

    I also just tried on another page on the same site with a gallery and saving the order worked. The difference is that the problematic gallery has 134 images, but the working one only has 37 images.

    I'm wondering if it's a HTTP request body size problem, but phpinfo() reports that the PHP post_max_size is 8M which should be plenty. It can't be exceeding that based on the time taken to submit the changes.

    Unless it's an Apache config problem... but I wouldn't expect LimitRequestBody to be set on commercial hosting.

  4. esmi
    Forum Moderator
    Posted 1 year ago #

    The difference is that the problematic gallery has 134 images, but the working one only has 37 images

    That does sounds like a POST limitation issue. Try asking your hosts about it.

Topic Closed

This topic has been closed to new replies.

About this Topic