WordPress.org

Ready to get started?Download WordPress

Forums

BackWPup Free - WordPress Backup Plugin
Inactivity Backup Errors (6 posts)

  1. newwestagency
    Member
    Posted 1 year ago #

    I have been getting these errors lately.

    [01-Jul-2013 11:13:09] WARNING: Job restart due to inactivity for more than 5 minutes.
    [01-Jul-2013 11:13:09] ERROR: ZipArchive returns status: (ER_DELETED) Entry has been deleted
    [01-Jul-2013 11:21:47] WARNING: Job restart due to inactivity for more than 5 minutes.
    [01-Jul-2013 11:35:14] WARNING: Job restart due to inactivity for more than 5 minutes.

    http://wordpress.org/extend/plugins/backwpup/

  2. dehab
    Member
    Posted 1 year ago #

    Same Issue that I am seeing - any updates

  3. George Lerner
    Member
    Posted 1 year ago #


    1. Trying to create backup archive …
    Compression method is ZipArchive
    WARNING: Job restart due to inactivity for more than 5 minutes.
    2. Trying to create backup archive …
    Compression method is ZipArchive
    WARNING: Job restart due to inactivity for more than 5 minutes.
    3. Trying to create backup archive …
    Compression method is ZipArchive
    WARNING: Job restart due to inactivity for more than 5 minutes.

    Set for 3 retries... This means the backup archive was Not created, right? In the backup folder, are numerous 0-byte files.

    a) Say clearly "Backup archive not created"
    b) How do I set the timeout?
    c) How do I estimate how long the timeout should be? (E.g. given how much was archived in 5 minutes, how long would the entire archive take?)
    d) I want to back up all the files of my site, excluding folders with huge files (audio, video I can back up separately). The resulting file size might be over 2GB. If just a small Multi-Site blog takes more than 5 minutes, the full backup needs a Much larger setting!
    e) Archive pieces are left in the backup folder. Are these useable? File names such as backwpup_1_2013-08-13_23-21-07.zip.Polk1B or backwpup_1_2013-08-13_23-21-07.zip.aZzqDu

    I have added to my wp-config this line:
    set_time_limit(3600); /* 1 hour */
    This should be in the plugin, set before each database or ZIP operation: set_time_limit(600); // 10 minutes

  4. obit8
    Member
    Posted 11 months ago #

    Lernerconsult what you have added works?

  5. George Lerner
    Member
    Posted 11 months ago #

    @obit8 No, the set_time_limit in wp-config does not work, I was stating that I had tried it. Setting the overall WordPress time limit to 1 hr is of course defeating the purpose -- it is to allow PHP to stop processes that are out of control. PHP allows specifying the timeout so you can give things like database queries that could take a little longer, or making .zip files which could take a long time, enough time to complete; that should be done in the plugin surrounding the specific time-consuming steps.

    I also have problems with WordPress plugin updates not unzipping, so there may be a problem with the zip functions on my WordPress, or my server, or some other plugin conflicting with zip, or.... I don't really have a way to test it, until I dive in to learning to write a PHP zip routine...

    Somewhere I posted that the tar format (no compression, just put everything in one file) worked for the database backup but not for "database plus all my folders"

  6. George Lerner
    Member
    Posted 10 months ago #

    There are older versions of PHP that have bugs with zip/unzip, hang with no error messages -- and make WordPress Update fail, make BackWPup compression fail, anything using zip/gzip.

    http://lcblog.lernerconsult.com/2013-php-unzip-bug-makes-wordpress-updates-hang/ has PHP code that demonstrates the bug isn't in WordPress or BackWPUp (if your version of PHP has the bug).

    BackWPUp works with compression after talking to my hosting provider, a .htaccess configuration change switched me to a newer PHP.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags