WordPress.org

Ready to get started?Download WordPress

Forums

HTML5 jQuery Audio Player
[resolved] Inability to Upload Songs (404/403 error) (9 posts)

  1. Ben Nichols
    Member
    Posted 1 year ago #

    When adding songs under MANAGE SONGS, I input the details of the song, however when clicking ADD SONG, I am taken to 'www.kalanibarnesmusic.com/wp-admin/admin.php?page=hmp_palylist' with a 404 error - on the 2nd blog a 403 error was given strangely. I have tried this on 2 blogs. Standard 2011 theme. Any assistance is appreciated.

    http://wordpress.org/extend/plugins/html5-jquery-audio-player/

  2. Maeve Lander
    Member
    Plugin Author

    Posted 1 year ago #

    Hi bnichols1707... this has not been reported before by anyone else, and I checked your site and there's no dodgy code or anything else that I can see that would be causing conflicts, so I suspect it is most likely a configuration error or an error with the song/s you are trying to add. Can you make sure you're entering all required fields and that file paths are correct? Maybe send a screenshot if the problem persists so I can have a closer look at what's going on?

  3. Ben Nichols
    Member
    Posted 1 year ago #

    Tried on a completely different blog, fresh install of wordpress. Error 403 - forbidden.
    http://imgur.com/a/141Nf#0

    The other blog was also on a separate server too. Anything you see stand out?
    Thanks for your assistance.

  4. Maeve Lander
    Member
    Plugin Author

    Posted 1 year ago #

    Ahha ok this looks like a permissions issue. Try adding this to your .htaccess file:

    <IfModule mod_security.c>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </IfModule>

    If that doesn't work you can run a Google search to find out more options as this issue is discussed all over the wordpress.org support forums. It's not an issue specifically related to this plugin.

    Hope this helps.

  5. Ben Nichols
    Member
    Posted 1 year ago #

    I've added the above to the .htaccess file, although unfortunately still have no luck. Still resulting with a 403 permissions error. Might ask the hosting company to have a look into it if I can't find anything on Google.
    Thanks for your help so far.

  6. Maeve Lander
    Member
    Plugin Author

    Posted 1 year ago #

    Ok sure. It's discussed all over the net and on a lot of other wordpress.org support forums. If you find a method that works maybe post back in case someone else stumbles across this thread and finds it useful.

  7. Ben Nichols
    Member
    Posted 1 year ago #

    Success! The hosting company had blocked some mod_security rules on all servers, yet once they saw my e-ticket, they allowed the 2 required and were investigating in others that should be allowed/whitelisted.

    Anyone who has this issue in the future, try the .htaccess update, and if no luck, send an e-ticket and ask them to confirm it.

    All the best.

  8. Jenny Pearce
    Member
    Posted 10 months ago #

    There must be a variety of causes to get this 404 error - because my audio upload 404 problem was just resolved by renaming the file and taking the numbers and apostrophe out of the file name.
    Woohoo!

  9. Maeve Lander
    Member
    Plugin Author

    Posted 9 months ago #

    Cool, thanks for posting your solution Jenny. I would always recommend avoiding weird characters/symbols for filenames, and replace spaces with dash or underscore. Web servers just don't handle that stuff too great!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic