WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] In the process of changing directory - No site! (46 posts)

  1. esmi
    Forum Moderator
    Posted 1 year ago #

    both the sireurl and home entries in the database have reverted back to:
    http://touchtitanium.com/touchtitanium/blog

    Are you sure? Have you checked the database manually?

  2. Milsie
    Member
    Posted 1 year ago #

    Yes, I have checked the database manually because I can only edit it manually. I copied and pasted that from the siteurl entry I had just updated. Just tried it again for a second time. Same results..

  3. esmi
    Forum Moderator
    Posted 1 year ago #

    Try the functions.php method of changing the site url.

  4. Milsie
    Member
    Posted 1 year ago #

    I had already tried this method and just found that I had left in those two lines of code, which were causing the problem.

    The site is now back up and running and looking grand: http://www.touchtitanium.com/

    Thank you for your help so far, esmi.
    Do you know how I can get my site to use touchtitanium.com as the domain name so that it displays touchtitanium.com/jewellery for example, in the address bar?

  5. esmi
    Forum Moderator
    Posted 1 year ago #

    Where is the touchtitanium.com domain name currently pointing to?

  6. Milsie
    Member
    Posted 1 year ago #

  7. Milsie
    Member
    Posted 1 year ago #

    This article looks interesting:
    http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory

    ..and the last option sounds best for me because it sounds simplest. But I tried it before and that's how this nonsense all began.

  8. esmi
    Forum Moderator
    Posted 1 year ago #

    OK - so use the functions.php method to change the urls to http://www.touchtitanium.com

  9. Milsie
    Member
    Posted 1 year ago #

    Done that. So now what about the rest of the links? Home page works but this page for example doesn't have anything to display

    http://www.touchtitanium.com/shop/

  10. Milsie
    Member
    Posted 1 year ago #

    I'm going to do it again. back in a moment..

  11. Milsie
    Member
    Posted 1 year ago #

    No luck. Still not displaying the shop or other pages. Just the home page (which is actually the root because the domain is set to forward)

  12. esmi
    Forum Moderator
    Posted 1 year ago #

    now what about the rest of the links?

    You need to set up a suitable permalink structure for your site via Settings -> Permalinks.

  13. Milsie
    Member
    Posted 1 year ago #

    My Site address and WordPress address should be different.. they both read the same..

    One should be the root and one the sub, but which way around?

  14. Milsie
    Member
    Posted 1 year ago #

    Actually it says:

    This is not necessarily the best fix, it's just hardcoding the values into the site itself. You won't be able to edit them on the General settings page anymore when using this method.

  15. Milsie
    Member
    Posted 1 year ago #

    Hey! It worked! I just moved the Permalinks setting to Custom then back to the original one and they appear to have been updated and site is working perfectly. I owe you a pint if you're in London.

  16. esmi
    Forum Moderator
    Posted 1 year ago #

    It might be flat by the time it reaches me in Liverpool but I appreciate the gesture. Glad to hear that the site is working for you now. :-)

Topic Closed

This topic has been closed to new replies.

About this Topic